Closed Bug 935486 Opened 6 years ago Closed 5 years ago

biography.com fails to play video on FirefoxOS, shows "requires Flash" error

Categories

(Web Compatibility :: Mobile, defect)

Other
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: hsteen, Unassigned)

References

()

Details

(Whiteboard: [mobile-compat-form] [video][M3U8][clientsniff] [country-us])

Site: http://www.biography.com/videos
biography.com fails to play video on FirefoxOS, shows "requires Flash" error

:: Steps To Reproduce

biography.com fails to play video on FirefoxOS, shows "requires Flash" error. It plays on iPhone, so there's a non-Flash alternative.

:: Expected Result

video

:: Actual Result

no video

:: Additional Information

Software Version: 1.1
Reporter's User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0
On the ipodtouch, it gives a desktop site, then when asking for videos, it start a fullscreen view with the videos playing.

On Opera Mobile, the square for the video appears, then clicking on the arrow starts something but fails to start the video.

On Firefox Android, it starts the video but come back to black with eventual flash of the video. and also scrollbars becoming gigantic by flashy period if put in fullscreen. Until the end of the video. 


So here again there is a full set of issues, which requires deeper analyzes.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [mobile-compat-form] → [mobile-compat-form] [video]
I see Firefox on Android tries to fetch a M3U8 playlist when I try to play at least the "Mini biography"-type videos, so certain features here depend on M3U8 support.
Depends on: m3u8video
Whiteboard: [mobile-compat-form] [video] → [mobile-compat-form] [video][M3U8]
Firefox OS doesn't get the HTML5 player due to this sniffing:

    pub.runtime = function() {
        // navigator.userAgent navigator.platform appVersion
        // only use HTML5 when it is iphone or ipad
        var value = navigator.userAgent.toLowerCase();
        if (value.indexOf("iphone") > -1 || value.indexOf("ipad") > -1 || value.indexOf("android") > -1)
            return "HTML5";

(Looks familiar - they "borrowed" code from Brightcove or something?)
Whiteboard: [mobile-compat-form] [video][M3U8] → [mobile-compat-form] [video][M3U8][clientsniff]
I won't mark this contactready yet (since getting the M3U8 HTML5 player won't help much) - let's see if there is a decision in bug 941351..
When it is time to contact. 
This is part of http://www.aenetworks.com/
Whiteboard: [mobile-compat-form] [video][M3U8][clientsniff] → [mobile-compat-form] [video][M3U8][clientsniff] [country-us]
Some content loads from e.g. Youtube and plays fine. However, video content like this JFK documentary:
http://servicesaetn-a.akamaihd.net/pservice/embed-player/?siteId=bio&tPid=32023476
still relies on M3U8
All the video I can find on the site (at a glance) now is embedded YouTube stuff - and those videos work fine. Do they still do self-hosted videos too?
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.