Project and tracking flag fields appear in Ember.create response when the user doesn't have permission to set them

RESOLVED INVALID

Status

()

bugzilla.mozilla.org
API
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Erik Bryn, Unassigned)

Tracking

Development/Staging
x86
Mac OS X

Details

(Reporter)

Description

4 years ago
As my user w/o editbugs permission, the project and tracking flag dropdowns are disabled in the existing UI. Screenshot: https://www.monosnap.com/image/M0BLNbyQDTz8PClxmvsKIYMbL

I would expect that the Ember.create response would not contain those fields since the user doesn't have permission to set them.
All tracking flags are visible but they are disabled (grayed out) until the user selects a component. At which time the drop down will enable and the possible choices are allowed. If a user cannot edit any values of the flag, then it just as the single option of '---',
(Reporter)

Comment 2

4 years ago
Ah, OK I see that, thanks for clarifying.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.