Firefox Freezes while loading Markers at https://location.services.mozilla.com/map_world

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Tyler, Unassigned)

Tracking

({perf})

Details

(URL)

(Reporter)

Description

5 years ago
Open https://location.services.mozilla.com/map_world in Nightly.
Map loads, but Firefox freezes for a few seconds while the markers generate and load on the map.

Latest Nightly
Sounds similar to bug 931369 i.e. caused by bug 923193
In my debug build, the hang is longer and it actually triggers a series of slow-script dialogs pointing to:
  https://location.services.mozilla.com/static/js/leaflet.min.js:6
  https://location.services.mozilla.com/static/js/leaflet.min.js:7
  https://location.services.mozilla.com/static/js/leaflet.markercluster.min.js:6

I think it's possible the script is just doing a lot of processing and hogs the main thread for a while.
[disregard troll comment 4]

I don't get any hits to either of the lines of code from comment 3, during the hang.

(I do hit those lines when I hover over the map, but that's unrelated.)
(In reply to Daniel Holbert [:dholbert] from comment #2)
> I think it's possible the script is just doing a lot of processing and hogs
> the main thread for a while.

Sysprof says this is the case. No SVG stuff shows up there; looks like we're spending all of our time doing JS work. (e.g. 10% in js::baseops::SetPropertyHelper, and lots of 2-6% chunks in a bunch of other functions in the js:: namespace, and 12% in nsJSContext::CycleCollectNow)

So I think this just boils down to "web pages can do lots of work on the main thread and hang the event loop" (until we pop up the slow script dialog after a few seconds).
Instruments on OSX agrees it's all JS.  Fwiw, Chrome also takes a good while to generate
the markers, although it doesn't block the UI while doing so.  I think we have bugs open
on separate UI/content processes to fix that.  I think the best we can do is give this
feedback to the developer of that web page.
Component: SVG → Other
Keywords: hang → perf
OS: Mac OS X → All
Product: Core → Websites
Hardware: x86 → All
Version: Trunk → unspecified
This is WFM using 28/Trunk. Anyone confirm to resolve?
(Reporter)

Comment 11

4 years ago
No problem for me anymore.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.