Thunderbird 24.1.0 hangs soon after startup on Mac

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: tjrob, Unassigned)

Tracking

({hang, perf, regression})

24 Branch
x86
Mac OS X
hang, perf, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2014-01-01][regression:TB24.1.0])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131025151332

Steps to reproduce:

I just updated Thunderbird to 24.1.0, as it automatically prompted me to do so. At least I think it is 24.1.0 -- I cannot verify the version as it is hung :(. It just updated this morning.

This is Mac OS X 10.7.5 (Lion).


Actual results:

After a minute or two it hangs forever (> 30 minutes). It might be downloading all messages from SentMail, I'm not sure. I can ForceQuit Thunderbird, but then it refuses to run again claiming a copy of Thunderbird is already open. A ps in Terminal shows a zombie named (thunderbird). The only recourse is to power-cycle the machine, because both logging out and restarting hang forever -- almost surely Thunderbird's fault; then it just happens again.


Expected results:

It should not hang. It should not prevent logging out or restarting.
(Reporter)

Comment 1

5 years ago
I power cycled and verified this is indeed Thunderbird 24.1.0.

I could use it for a minute or two, then it hung for at least 5 minutes. The status line at the bottom says "Downloading 5608 of 9926 in Sent Mail"; that is a gmail account.

Before it hung I noticed that the downloading was rather slow (judging by the incrementing count); I typically have 10MBit/sec connectivity, and it should be much faster. If it started from 1 (I didn't notice), then the first 5000 were indeed much faster.

Right now, Thunderbird is completely unusable for me. I have been using it since before it was called Thunderbird.
Severity: normal → blocker
Priority: -- → P5
(Reporter)

Updated

5 years ago
Priority: P5 → P1
(Reporter)

Comment 2

5 years ago
Sorry it took three tries to figure out what Importance values meant. A popup or link in the bug report page would be good.
Severity: blocker → critical
(Reporter)

Comment 3

5 years ago
I power-cycled to get rid of the (thunderbird) zombie. I then downloaded and installed Thunderbird 24.0.1 (the previous version which I had been using for several weeks). Crossing my fingers that 24.1.0 did not screw up the configuration or change it incompatibly, I ran Thunderbird 24.0.1. It runs fine, and I have now been using it for at least 10X longer than 24.1.0 took to hang. 

So I'm pretty sure that some change in 24.1.0 caused the problem. 

(I proofread those version numbers several times, as they are very confusable.)
(Reporter)

Comment 4

5 years ago
Curiouser and curiouser.

Upon arriving home I discovered that my laptop, a MacBook Air also running Max OS X 10.7.5 (Lion), has been running Thunderbird 24.1.0 for 3 days without problems. All the previous comments were about my Mac Pro at work.

The email configurations of my two machines are as close to identical as I could make them (probably not perfect).

This does not mean that Thunderbird 24.1.0 works on my Mac Pro, it just means that the problem is most likely more subtle than a simple coding error.

Comment 5

5 years ago
Are these gmail accounts defined as pop? 
How many accounts?
Flags: needinfo?(tjrob)
Keywords: hang, perf
Priority: P1 → --
(Reporter)

Comment 6

5 years ago
My gmail account is IMAP. BTW it is a business account; it totals 4.59GB. I access it primarily via Thunderbird on these two Macs, plus occasionally via its webmail and via the gmail app on an Android phone.

Both systems have my main gmail (IMAP) account, a POP3 account at sbcglobal.net (hosted by Yahoo), the usual Local folders, and a Giganews account (newsgroups).

I just realized that on the Mac Pro (which hangs), I recently added a new identity for my main gmail (IMAP) account, making a total of four; the laptop (no hang) has only three identities for that gmail account. The other accounts each have a single identity. I don't know if this matters.

As these two systems behave so differently in Thunderbird 24.1.0, I intend to make a detailed comparison of their configurations.
Flags: needinfo?(tjrob)

Comment 7

5 years ago
start thunderbird with 
   -offline
switch on the command line.  Then change account settings of all accounts to not get new mail on startup, and not get new mail on interval. Then restart thunderbird without "-offline". All should be well

Then, enable/get new mail one account at a time to determine which account is causing difficulty
(Reporter)

Comment 8

5 years ago
Things just got even curiouser.

I did NOT do anything that Wayne Mery suggested; nor did I get around to comparing configurations. But I did reboot my Mac Pro (the one that hangs). That caused Thunderbird to restart, and I didn't notice that it updated itself to 24.1.0. I used it for several hours before checking its version and being surprised by 24.1.0 -- that was considerably longer than that version had ever gone before without hanging. Moreover, one reboot had trouble even though I had specifically NOT run Thunderbird, so something else is causing that problem.

It has now been more than a day that Thunderbird 24.1.0 is running fine on both of my Macs. So I don't think I can be much help in diagnosing/debugging it. Unless someone suggests otherwise, or the problem returns, I'll mark this bug as RESOLVED on Monday. It's frustrating that we don't know what resolved it.

Comment 9

5 years ago
Yes, the "unknown" is frustrating.

What is shown at options | advanced | update | show update history ?
Flags: needinfo?(tjrob)
(Reporter)

Comment 10

5 years ago
Created attachment 829758 [details]
Screen Shot 2013-11-09 at 11.50.21 AM.png

update history on my Mac Pro (which used to hang). (The path you gave was presumably for Windows, but I found it on my Mac.)
Flags: needinfo?(tjrob)
(Reporter)

Comment 11

5 years ago
I suspect the problem is related to downloading a very large number of headers (or emails) from my gmail account. If so, then it no longer hangs because after several (interrupted) trials it finished. Perhaps power-cycling the machine with Thunderbird hung while downloading does something bad to its configuration/data files (but then I don't know how it finished without hanging). 

Is there some simple way I can make Thunderbird download the entire "Sent Mail" folder again?

I suppose I could simply subscribe to "All Mail", which would presumably download every message (remembering that in gmail "folders" are merely tags). But I suspect that gmail's IMAP interface treats All Mail differently from other folders, so it might not be a good test.

Comment 12

5 years ago
Do you see same behavior when TB 24.1.0 is started in safe mode?
https://support.mozillamessaging.com/en-US/kb/safe-mode
Flags: needinfo?(tjrob)
Keywords: regression, regressionwindow-wanted
Summary: Thunderbird 24.1.0 hangs on Mac → Thunderbird 24.1.0 hangs soon after startup on Mac
Whiteboard: [regression:TB24.1.0]

Comment 13

5 years ago
Tom?
Whiteboard: [regression:TB24.1.0] → [closeme 2014-01-01][regression:TB24.1.0]

Comment 14

5 years ago
This went away on its own. Due to a complete system failure and replacement, I can no longer explore it.
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(tjrob)
Resolution: --- → WORKSFORME
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.