Northwestern University Webmail using invalid URL

VERIFIED FIXED

Status

VERIFIED FIXED
17 years ago
4 years ago

People

(Reporter: mozilla.org, Assigned: doronr)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.3) Gecko/20010801
BuildID:    20010801

Mozilla seems to be misinterpreting the URL given in the action attribute for
the form, and thus attempts to post to the wrong URL (which, of course, does not
work).

Reproducible: Always
Steps to Reproduce:
1. Go to https://webemail.it.northwestern.edu/cgi-bin/webemail_login
2. Click the button labeled "Login".

Actual Results:  An Alert dialog pops up that says "The connection was refused
when attempting to contact www.cgi-bin.com".

Expected Results:  Mozilla should attempt to POST the form to
"https://webemail.it.northwestern.edu/cgi-bin/nph-check-mail"

This works correctly in IE 5.5 and NS 4.73. I saw the same error in 0.9.2
(haven't tried it in any other Mozilla versions).
<form METHOD="POST" ACTION="https:/cgi-bin/nph-check-mail"

https:/ with one slash is an invalid URL.  See bug 32966 for discussion.  Over
to evangelize.
Assignee: rods → bclary
Status: UNCONFIRMED → NEW
Component: Form Submission → Evangelism
Ever confirmed: true
QA Contact: vladimire → zach
taking
Assignee: bclary → caillon
Status: NEW → ASSIGNED
*** Bug 68977 has been marked as a duplicate of this bug. ***
Here is a response I got:

Christopher Aillon,

We have no plans at this time to support Netscape 6.  Please see the 
November 29, 2000 "Netscape 6 Not Recommended At This Time" notice further 
down the login page.  We recommend a Netscape 3, 4 or IE 3, 4 or 5 browser.

If a user would like an RFC 2396 compliant login page, there is one available
at:

  https://webemail.it.northwestern.edu/cgi-bin/webemail.login.rfc2396

However, the rest of The WebEmail Gateway may not function well and the
use of Netscape 6 is unsupported for The WebEmail Gateway because the 
handling of frames and HTTPS is very awkward.

Sorry for the inconvenience,

Summary: attempts to POST to wrong URL → Northwestern University Webmail using invalid URL and not supporting Mozilla/NS6
MORE:

Oops.  I mis-spelled the link:

  https://webemail.it.northwestern.edu/cgi-bin/webemail_login.rfc2396

There are no plans to move in the direction that you're proposing at this
time.

Sorry for the inconvenience.

Comment 6

17 years ago
oops!  shoulda caught this one earlier.  

i nagged the IT/TSS/TOFKAA staff about this one until they finally put up the
page with the proper url about six months ago.  unfortunately, i'm no longer at
n.u., but i was promised that if mozilla could operate correctly with the new
url (and with the webemail gateway as a whole) it would become the new default
webemail index page, since both navigator and ie work with the rfc2396 page. 
this has been the case since moz0.9, as far as i know.

if someone can keep up the nagging, i'll e-mail in as an alum and try to push
any connections there that i have left.

good luck.
Ratman, cool.  If you have any contacts with authority, it would be great. I
think I might have gotten a programmer who maybe has a lot on his plate so
obviously he is less than willing to help out.  A point to notice is that NWU
has a commitment to "adhere to the Web Content Accessibility Guidelines (WCAG)
of the World Wide Web Consortium (W3C)."
( http://www.northwestern.edu/univ-relations/web_comm/standards/access.html )

This might be one of the key points that actually get this fixed.  The web email
gateway violates quite a few of their guidelines posted on the above page, so
this might be a good avenue to take.  I don't have a login account obviously, so
really all  there is left now is just nagging them for W3C Standards compliance.
 Stress that and not NS 6/Mozilla support.

I've got some more info that could be of help if a student/alum wants to contact
them.
You know, the reporter's original issue (the non-RFC 2396 compliant page) has
been fixed sort-of, so I am changing the Summary back (not sure why I changed it
to be so specific) and resolving this as fixed.  Come to think of it, I only
asked him to change the FORM ACTION="" URL which there is a resolution to.

Anyway, bug 93709 is posted for the remaining issues so please take any further
discussion on that issue to that bug.  Feel free to join the CC list on that one :)
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Summary: Northwestern University Webmail using invalid URL and not supporting Mozilla/NS6 → Northwestern University Webmail using invalid URL

Comment 9

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 10

17 years ago
seems to work although it doesn't like foo/bar as the login data. ;-) verified
Status: RESOLVED → VERIFIED

Comment 11

17 years ago
SPAM.  You may filter these bugs by querying the string "ReadingRitingRithmetic"

Mass Moving Bugs on Educational institutions in the United States to the new US
Edu component and assigning to default owners.
Assignee: caillon → doronr
Component: US General → US Edu
QA Contact: zach → caillon

Comment 12

16 years ago
tech evang june 2003 reorg
Component: US Edu → English US
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.