padding-bottom not rrespected in a box with an height fixed

RESOLVED INVALID

Status

()

Core
General
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: marcocek1995, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20131030 Firefox/17.0 Iceweasel/17.0.10 (Nightly/Aurora)
Build ID: 20131031012853

Steps to reproduce:

http://supercek.altervista.org/site/content/basepages/contact.php
This is the site. Now go to the main (in the center of the page) and scroll it down... Now analize the padding bottom.. It is not respected... Using chrome there's no problem. I try to anlize better this problem with firebug but I can't understand why it happens


Actual results:

The padding-bottom of the div main is not respected


Expected results:

Padding-bottom of the div main should be displayed how in chrome
(Reporter)

Comment 1

4 years ago
Sorry for my english
The spec requires the Gecko behavior: bottom padding doesn't increase the scrollable area of a scrollable box.
Whiteboard: DUPEME
(Reporter)

Comment 3

4 years ago
so? what I nave to do? isn't it a bug? in chrome it works well.. when I analize the box with firebug I see the right padding. how to solve? thank you so much
(Reporter)

Comment 4

4 years ago
(In reply to Boris Zbarsky [:bz] from comment #2)
> The spec requires the Gecko behavior: bottom padding doesn't increase the
> scrollable area of a scrollable box.

so? what I nave to do? isn't it a bug? in chrome it works well.. when I analize the box with firebug I see the right padding. how to solve? thank you so much
> isn't it a bug?

No, it's not.

If you want to have a padding _inside_ the right/bottom scrollbars, you want to put it on something that's not the scrollable element.
(Reporter)

Comment 6

4 years ago
solved
thank you so much
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.