Moving Downloads Button to Customize Palette breaks the button

VERIFIED FIXED in Firefox 27

Status

()

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: mcdavis941.bugs, Assigned: Gijs)

Tracking

(Blocks 1 bug, {regression})

27 Branch
Firefox 28
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox26 unaffected, firefox27+ verified, firefox28 verified)

Details

(Whiteboard: [Australis:M?][Australis:P3])

Attachments

(1 attachment)

Not sure how much this matters with all the Australis work, but anyway, with Firefox 27 Aurora, if you move the Downloads Button to the Customize Toolbars palette then back to the toolbar then start a long download, the button doesn't show the counter and progress meter, but I think it's meant to (because that's what happens if you don't customize first).

STR:
1. Firefox 27, fresh profile, no add-ons.
2. Should see Downloads Button in the toolbar, in a normal state (no activity, not alerting).
3. Open any page in a tab, save some image from that page to disk.
4. Downloads Button shows the icon in an alerting state, colored, indicating a new completed download.  (It looks like if it's the very first download ever in this new profile, it opens the popup for you automatically instead of alerting; if that happens, just cancel all downloads, restart the browser then follow these STR.)
5. Customize toolbars, drag the Downloads Button to the palette (removing from the toolbar) and exit customization mode.
6. Customize toolbars, drag the Downloads Button from the palette to the toolbar, and exit customization mode.  The Downloads Button should now be back in the toolbar.
7. Visit this page and start the offered ISO download, saving to disk: http://www.ubuntu.com/download/desktop/thank-you?distro=desktop&bits=32&release=lts
8. The Downloads Button is expected to now be showing a counter (time remaining) and progress meter, but instead it's still showing just the alert icon.
9. Also, you should be able to open the downloads panel popup to acknowledge the alert and get the normal icon back, but opening the panel doesn't change the icon.

Expected results:
- Downloads Button shows counter and progress meter for active download

Actual results:
- Downloads Button continues to show alerting-state icon

This is Firefox 27 on Windows Vista 64.
Whiteboard: [Australis:M?][Australis:P3]
This probably broke because of my refactoring in bug 845408 and related bugs. :-(
Keywords: regression
AFAICT the problem is we reset _operational, but because _hasDownloads remains true, we never try to make the button operational again.
Attachment #830147 - Flags: review?(mconley)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
OS: Windows Vista → All
Hardware: x86_64 → All
Comment on attachment 830147 [details] [diff] [review]
should ensure button is operational when it's not,

Review of attachment 830147 [details] [diff] [review]:
-----------------------------------------------------------------

Yep, this makes sense. Thanks Gijs.
Attachment #830147 - Flags: review?(mconley) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/ac79c0e3b30f
Depends on: 845408
Whiteboard: [Australis:M?][Australis:P3] → [Australis:M?][Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/ac79c0e3b30f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M?][Australis:P3][fixed-in-fx-team] → [Australis:M?][Australis:P3]
Target Milestone: --- → Firefox 28
Comment on attachment 830147 [details] [diff] [review]
should ensure button is operational when it's not,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 845408
User impact if declined: The downloads button stops being functional if it's been customized away and then put back in the same browser session.
Testing completed (on m-c, etc.): Local testing, baking on m-c
Risk to taking this patch (and alternatives if risky): Very low risk, as it's a localized change to when we (re)run initialization code for the button to ensure we do that in this case, whereas we weren't before.
String or IDL/UUID changes made by this patch: None.
Attachment #830147 - Flags: approval-mozilla-aurora?
Comment on attachment 830147 [details] [diff] [review]
should ensure button is operational when it's not,

Approving the low risk patch on aurora to avoid shipping with this regression. Also adding qawanted, verify to get some adhoc testing around downloads(related to https://bugzilla.mozilla.org/show_bug.cgi?id=845408) and verify this bug
Attachment #830147 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
I was able to confirm the fix for this issue on:
- Windows 7 x64, using:
* Aurora 27.0a2 (BuildID: 20131127004001): Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0
* Nightly 28.0a1 (BuildID: 20131128030201): Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:28.0) Gecko/20100101 Firefox/28.0

- Windows Vista x64, using:
* Aurora 27.0a2 (Build ID: 20131127004001):  Mozilla/5.0 (Windows NT 6.0; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0
* Nightly 28.0a1 (BuildID: 20131128030201):  Mozilla/5.0 (Windows NT 6.0; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
Status: RESOLVED → VERIFIED
Keywords: qawanted, verifyme
You need to log in before you can comment on or make changes to this bug.