Option for smart screen-timeout with eye-recognition

RESOLVED WONTFIX

Status

Firefox OS
General
--
enhancement
RESOLVED WONTFIX
5 years ago
3 months ago

People

(Reporter: Carlos F, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131025151332

Steps to reproduce:

There should be an option to keep the screen on, as long as the front-cam recognizes that eyes are looking at it. And only if it recognizes that eyes aren't looking at it for the chosen delay-time the screen is turned off.

Updated

5 years ago
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

5 years ago
I know this from Samsung Galaxy Tablets and Phones. And it's a really great feature. A small detail, but it brings a huge improvement to usability.

Comment 2

5 years ago
Maybe this is more a problem of Head-Tracking rather than Eye-Tracking. If you do Head-Tracking, the head will be recognized as long as it is facing the camera, which is basically what we want. (if you're facing the camera this means you're looking at the device, no need to look at the eyes).
There is this library : https://github.com/auduno/headtrackr/ which allows head-tracking. This could be used here pretty easily.

The real problem is more power consumption and CPU usage. Having the camera constantly working with a tracking algorithm on top of that will require constant CPU resources and may slow down the other apps and kill the battery. However Samsung devices are doing it so there must be a solution that is not too resource hungry.

Comment 3

4 years ago
But Samsung does it with eye-recognition. I've tried it and when I close the eyes for a while, the display turns off. With head-recognition I also see another problem. When I hear music I often hold the phone in a position (diagonally under the face), where I don't look directly on the screen until the title ended and I search for a new one. In this position the cam would see my head but my eyes are not looking at the display.

CPU-usage: as you said - when Samsung uses it, there must be a way to do it in a manner that works for mobile devices with limited power. And of course, this should only be an option, that you can toggle on/off because some people maybe don't want it.

Comment 4

4 years ago
(In reply to hugohh94 from comment #2)

> The real problem is more power consumption and CPU usage. Having the camera

Maybe this could even reduce the power consimption. Because many users set the screen-delay to a very high value so that they don't have to always touch the screen while reading a webpage, a PDF, or anything like that.

With eye-recognition that could be set much lower so that the screen isn't activated that much. And because the screen is the biggest power-consumer, that feature could even save power.

Of course that shoule be an option, that the user can activate/deactivate. And by default it shoule be turned off, because it also has impact on privacy, when the camera is always on while using the device. But as an additional option it would be great.

And I also agree, that it should be eye-recognition and not head-recognition. Because a head doesn't mean, this head is looking on the display. Only eye-recognition (more exact the pupils) is the best solution for that. Just like Samsung does it in its Galaxy-devices (smartphones and tablets).

Comment 5

3 years ago
That would be a very interesting feature. 

And as an option every user could choose if he wants that feature or longer battery-runtime. But as Pascal explained above, this maybe could even extend the battery-runtime.

Comment 6

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.