thehigherauthority.com--text color missing # results in black on black text

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: jmbelo, Assigned: bc)

Tracking

Details

(Whiteboard: [DOCTYPE][aok], URL)

(Reporter)

Description

17 years ago
Go to http://www.thehigherauthority.com/apollo.html

Your expecting to see an image and some yellow text, you only see an image.

If you try it with ms-ie-5.5 or ns-4.08 you see the text.

OS:MS2000 
MOZ version: Milestone 0.93

Comment 1

17 years ago
The text is there, it's just in black. Have them fix the page.

<BODY BGCOLOR="#000000" TEXT="FFFF00">
                              ^
                              should be a hash there

Thanks for the report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 2

17 years ago
.
Status: RESOLVED → UNCONFIRMED
Component: Browser-General → Evangelism
Resolution: INVALID → ---

Comment 3

17 years ago
.
Assignee: asa → bclary
QA Contact: doronr → zach
Summary: In this page is an image and some text, Mozilla only shows the image → text color missing # results in black on black text
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 5

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 6

17 years ago
what is the status of this bug? Adding WRMB, cc marek and chofmann
Keywords: topembed
Summary: text color missing # results in black on black text → WRMB: text color missing # results in black on black text
(Assignee)

Comment 7

17 years ago
why is this topembed?
Priority: -- → P1
Summary: WRMB: text color missing # results in black on black text → thehigherauthority.com - WRMB: text color missing # results in black on black text

Comment 8

17 years ago
if we could easily solve the problem in the client would that be a better
solution  since 4x and IE seem to handle this quirk?

looks like there is a z order problem on the horizontal lines that go
through the appollo image on the left side..
Keywords: 4xp

Comment 9

17 years ago
talked with attinasi -- and we figured out that the doctype is missing the 
Transitional phrase. If the 'correct' dtd is used:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

it works like a champ, but the one used in the document:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN">

is not recognized, but we seem to treat it as standard mode and not quirks mode. 
 March pointed me to bugs 61901 and 44340
(Assignee)

Comment 10

17 years ago
ok. removing topembed and returning to a regular docytype evang bug.
Keywords: topembed
Whiteboard: [DOCTYPE]

Comment 11

17 years ago
I reviewed the spec (http://www.w3.org/TR/html4/) and the doctype statement:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN">
is the doctype for strict mode, all color specific attributes are deprecated in 
the strict DTD, so this is really a evang issue.

Comment 12

17 years ago
i neglected to finish my statement:
although the attributes are deprecated, they must be honored. In strict mode, 
the # is required, in transitional (loose) mode the # does not necessarily need 
to be there.

Comment 13

17 years ago
handing this one over to harish to start with
Assignee: bclary → harishd
Keywords: topembed
Summary: thehigherauthority.com - WRMB: text color missing # results in black on black text → WRMB: text color missing # results in black on black text

Comment 14

17 years ago
I don't think that this should be a topembed. In the transitional mode ( which
is majority of the web ) we seem to render as expected. I'll investiage the
behavior for strict mode.

FYI: If it turns out that in the strict mode '#' is optional then the decision
has to be made at the layout level not in the parser. Parser always functions in
quirks mode ( except for comment parsing ).

Comment 15

17 years ago
The '#' is not optional in strict mode. I stringly recommend we continue to
require it in strict mode.

Comment 16

17 years ago
I am pretty sure that Tech Evangelism bugs should not be topembed. If 
this is a Mozilla bug, it needs to be sent to the component that can best 
handle this, Layout probably. Otherwise, we should remove topembed. 
Somehow, I highly doubt that embedders around the globe are refusing to 
use gecko because thehigherauthority.com doesn't render correctly.
Summary: WRMB: text color missing # results in black on black text → http://thehigherauthority.com--WRMB: text color missing # results in black on black text

Comment 17

17 years ago
Based on Marc's last comment it looks like we're exhibiting the correct behavior
in quirks and strict modes. That is, the site has to be evangelised.

Comment 18

17 years ago
Ok, topembed removed then. Move along folks, nothing to see here.
Keywords: topembed
(Assignee)

Comment 19

17 years ago
ok. we will contact the site.
reassigning to default owner and removing topembed from the bug.

Unless the rest of you on the cc: list want to be subjected to evangelism spam,
I recommend that you remove yourself or tell me and I will do it for you.
Assignee: harishd → bclary
(Assignee)

Updated

17 years ago
Summary: http://thehigherauthority.com--WRMB: text color missing # results in black on black text → thehigherauthority.com--text color missing # results in black on black text

Updated

17 years ago
Whiteboard: [DOCTYPE] → [DOCTYPE][aok]

Comment 20

17 years ago
removing myself from the cc list
page gone.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.