Mozilla fails a portion of the W3C's CSS1 Test Suite: 5.5.02 margin-right

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
17 years ago
17 years ago

People

(Reporter: Brian Clark, Assigned: karnaze (gone))

Tracking

({css1})

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.3) Gecko/20010802
BuildID:    2001080214

Mozilla 0.9.3 for MacOS 9.1 fails a portion of the W3C's CSS1 Test Suite: 5.5.02
margin-right.

There are a few text elements on the page that are not rendered properly.  I am
not sure if it is related to the "margin-right" handling or not, but it
definitely is a layout issue.  

  



Reproducible: Always
Steps to Reproduce:
1.Go to the above web page
2.Load the page
3.Look for the text string "inline element of class two, which"
4.Notice that the comma and the word "which" are not laid out properly

Comment 1

17 years ago
Reporter, the .one and .two styles on this page appear to work properly under 0.9.3. Can 
you be more specific about what's wrong here?

Marking WFM for now, feel free to reopen if appropriate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Keywords: css1
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

17 years ago
Created attachment 44687 [details]
screenshot of this problem
(Reporter)

Comment 3

17 years ago
I attached a screen shot of what I am seeing.  I could be misinterpreting what
the test is supposed to show.  If it is supposed to look like this, then I stand
corrected. 
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 4

17 years ago
Reporter, based on the style rules, this looks right to me. Can you describe exactly what 
you think the problem is?

Comment 5

17 years ago
I see the same thing as Brian's attached screenshot. That is the correct layout
for that test. Resolving INVALID, build 2001-08-08-04 on Windows 98 SE.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.