Closed Bug 936008 Opened 6 years ago Closed 6 years ago

crash in java.lang.NullPointerException: at org.mozilla.gecko.gfx.LayerView.setZoomConstraints(LayerView.java)

Categories

(Firefox for Android :: Toolbar, defect, critical)

28 Branch
All
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 29
Tracking Status
firefox27 --- unaffected
firefox28 + fixed
firefox29 + fixed
fennec + ---

People

(Reporter: aaronmt, Assigned: wesj)

References

Details

(Keywords: crash, regression, steps-wanted)

Crash Data

Attachments

(2 files)

This bug was filed from the Socorro interface and is 
report bp-6ec12421-8976-4568-9de5-8b22d2131106.
=============================================================

ava.lang.NullPointerException
	at org.mozilla.gecko.gfx.LayerView.setZoomConstraints(LayerView.java:349)
	at org.mozilla.gecko.gfx.LayerView.onTabChanged(LayerView.java:668)
	at org.mozilla.gecko.Tabs$5.run(Tabs.java:572)
This probably happens because LayerView can be destroyed and re-created (particularly if you have "Don't keep activities" enabled) and the code in bug 932690 assumes that will never happen. It needs to unregister itself on destroy.
Blocks: 932690
Keywords: regression
Assignee: nobody → wjohnston
Attached patch PatchSplinter Review
Seems like a good patch regardless, but I don't see this crash with don't keep activities set...
Attachment #829461 - Flags: review?(bugmail.mozilla)
Comment on attachment 829461 [details] [diff] [review]
Patch

Review of attachment 829461 [details] [diff] [review]:
-----------------------------------------------------------------

Well hopefully the crashstats will let us know one way or the other.
Attachment #829461 - Flags: review?(bugmail.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/81e01946ed20
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
Still crashing on Android 4.0+ devices.

samsung     SM-P600         18 (REL)
PANTECH     PantechP9090    16 (REL)
LGE         Nexus 4         19 (REL)
samsung     GT-I9100        19 (UNOFFICIAL)
unknown     MID9742         15 (REL)
samsung     GT-I9300        16 (REL)
samsung     GT-N7000        17 (REL)
asus        Nexus 7         19 (REL)
samsung     GT-I9070P       16 (REL)
OUYA        OUYA Console    16 (REL)
samsung     GT-I9000        19 (REL)
Status: RESOLVED → REOPENED
tracking-fennec: --- → ?
Resolution: FIXED → ---
tracking-fennec: ? → +
#9 on Fx29 (nightly)
#1 on Fx28 (aurora)
Looking at a recent stack from one of the crash reports, it looks like this must be happening between when the LayerView is constructed and when intializeView is called on it, because that's the only time mLayerClient is null.
Attached patch Patch attempt 2Splinter Review
Possible fix. I haven't compiled or tested it at all yet.
The above try push had failures, probably because it was based on a bad inbound build. I rebased on m-c and repushed and it's looking much better:

https://tbpl.mozilla.org/?tree=Try&rev=365c5459c65a
Attachment #8360513 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/5327f5b72d98
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
please provide an uplift nomination
Comment on attachment 8360513 [details] [diff] [review]
Patch attempt 2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 932690
User impact if declined: crashes (this is apparently an Android topcrasher)
Testing completed (on m-c, etc.): not really since it's hard to reproduce locally. we should keep an eye on the crash stats to verify the fix before uplifting.
Risk to taking this patch (and alternatives if risky): pretty low-risk; the code is well understood. affects Fennec only
String or IDL/UUID changes made by this patch: none
Attachment #8360513 - Flags: approval-mozilla-aurora?
The patch seems to have worked; crash-stats reports that the latest nightly to crash with this problem was on the 14th of jan.
Attachment #8360513 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.