Add option to group similar entries in web console

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
5 years ago
3 months ago

People

(Reporter: sjw, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
It would be nice if there is an option to group similar entries (like fallbacks) in the console. This would improove debugging on Firefox a lot.


Example:

1  .one {
2  	background: -webkit-linear-gradient(top, gold, orange);
3  	background: -moz-linear-gradient(top, gold, orange);
4  	background: -o-linear-gradient(top, gold, orange);
5  	background: linear-gradient(to bottom, gold, orange);
6  	[...]
7  }
8  .two {
9  	background: -webkit-linear-gradient(top, gold, orange);
10 	background: -moz-linear-gradient(top, gold, orange);
11 	background: -o-linear-gradient(top, gold, orange);
12 	background: linear-gradient(to bottom, gold, orange);
13 	[...]
13 }


The Web Console find an error on line 2, 4, 9 and 11. So I see two way to group them:
A) Grouping by error: The Console make a group "backgroud: -webkit[...]" line 2 and 9 and a group "background: -o[...]" with the lines 4 and 11.
B) Grouping by rules and properties: The Console make a group ".one background" with line 2 and 4 and another group ".two background" with line 9 and 11.

I think scenario A would be helful if you made the same mistake in the whole document. The seccond one would be helpful to ignore fallbacks.
It's like the idea I described in #870487, there is also an exaple with the old error console (see https://bug870487.bugzilla.mozilla.org/attachment.cgi?id=747548).

Updated

5 years ago
Severity: normal → enhancement
Version: unspecified → Trunk
Component: Developer Tools: Debugger → Developer Tools: Console
Thanks for the feature request. During triage we decided this is a WONTFIX bug. We might hide CSS warnings caused by vendor prefixes. I can't find the bug number now, but we should have that already filed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

5 years ago
But what about prefixed values and properties that are not implemented yet?

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.