Closed Bug 936050 Opened 9 years ago Closed 9 years ago

If the user attempts to install a previous purchased app they will receive an error message. | Crow

Categories

(Marketplace Graveyard :: Payments/Refunds, defect)

Other
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: vikas.nanda, Unassigned)

References

Details

Attachments

(2 files)

Attached image 2013-11-07-17-51-33.png
steps to reproduce:

1. Start the MP Stage application. 
2. Attempt to install a previous purchased app. 


expected behavior:
The application should install

observed behavior:
The error message is presented to the user which reads App install error: Reinstall forbidden
Attached file ezboot-http.log
I'm not sure that this is a payments issue, but the fact that we are testing the Marketplace as a hosted app. See https://bugzilla.mozilla.org/show_bug.cgi?id=874646#c16. It sounds like testing payments of packaged apps, not hosted apps is the way to go.
Flags: needinfo?(krupa.mozbugs)
This is an expected error because you're using a hosted marketplace (not a packaged marketplace) and you are trying to install a packaged app. Once we have bug 877531 and a packaged stage app we can fix issues like this.

If you search ":hosted :paid" you should find apps that can be purchased and re-installed on stage.
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: needinfo?(krupa.mozbugs)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.