Australis panel doesn't fit to menu button

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: sjw, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:P5])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 828742 [details]
australis_small.png

If there are a lot of items in the menu panel and the window is not height enough, the panel does not longer fits to the menu button.
(Reporter)

Updated

5 years ago
Blocks: 872617

Comment 1

5 years ago
Mike, do you know if we could even do something about this? I somewhat suspect not...

I'm tending towards P-, tbh, but P5 for now as this isn't exactly a likely scenario.
Flags: needinfo?(mconley)
Whiteboard: [Australis:P5][Australis:M?]

Comment 2

5 years ago
(In reply to :Gijs Kruitbosch from comment #1)
> Mike, do you know if we could even do something about this? I somewhat
> suspect not...

Implement a pager / overflow widget? It's not great UI but much better than this (and it'll probably not happen too often).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

5 years ago
(In reply to Florian Bender from comment #2)
> (In reply to :Gijs Kruitbosch from comment #1)
> > Mike, do you know if we could even do something about this? I somewhat
> > suspect not...
> 
> Implement a pager / overflow widget? It's not great UI but much better than
> this (and it'll probably not happen too often).

There's already a scrollbar. The problem is, even if we were to reduce the max height of the scrollable container, if you move the window too close to the bottom of the screen, this situation will happen anyway.
I think this is something we'd have to fix in the panel code.

This isn't high priority, IMO. I think for users who want to stuff a bunch of things into the menu panel, something like a "list" mode would work better instead of the grid.
Flags: needinfo?(mconley)
(Reporter)

Comment 5

5 years ago
I'll just make sure that we talking about the same: I meant, that the arrow on the top of the panel doesn't fit to the menu button, not that the panel is longer than the window.
(In reply to sjw from comment #5)
> I'll just make sure that we talking about the same: I meant, that the arrow
> on the top of the panel doesn't fit to the menu button, not that the panel
> is longer than the window.

That's correct. The XUL panel code is trying to compensate for the lack of screen real-estate by moving to the top of the anchor.
Whiteboard: [Australis:P5][Australis:M?] → [Australis:P5]
Isn't this fixed by now - at least on Windows?
see http://imageshack.com/a/img853/9030/vwfd.png
Well, if the reporter thinks so as well, we can certainly call it that!
Flags: needinfo?(sjw)
(Reporter)

Comment 9

5 years ago
Seems fixed in Windows and Linux.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(sjw)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.