Print dialog does not stay on top

VERIFIED FIXED

Status

()

VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: kaie+oldbugzilla, Assigned: dcone)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
When I chose print in Linux, the print dialog comes up. This dialog is modal as
expected. However, when you accidentially click into the parent window (the
browser window), the print dialog is moved behind the browser window, it's now
hidden, and the normal user will be confused, as the application seems to no
longer responsive.

Expected behaviour: Dialog stays always on top of browser window.

See bug 90997.
(Reporter)

Comment 1

17 years ago
Created attachment 44671 [details] [diff] [review]
Suggested fix
(Reporter)

Comment 2

17 years ago
Adding patch, review keywords.

Requesting review.
Status: NEW → ASSIGNED
Keywords: patch, review
(Assignee)

Comment 3

17 years ago
Do you just need a review, or do you want this checked in also.
(Reporter)

Comment 4

17 years ago
Would be great if you could check it in for me, as I don't have yet permissions.
Thanks.
(Assignee)

Comment 5

17 years ago
r=dcone
(Reporter)

Comment 6

17 years ago
Thanks for r=. I'm meanwhile able to check in myself, so I can do it, once we
have sr=.

Comment 7

17 years ago
Looks ok, but I really don't know this code...

Comment 8

17 years ago
Looks fine to me, but can't we factor that code that is repeated for every
platform into a generic helper method? It looks to be platform neutral. Maybe a
helper routine called GetDialogParent or something. Also, what has been done to
test this?
(Assignee)

Comment 9

17 years ago
Windows and Mac the Dialog stays on top already.. so this is not an issue there.
(Reporter)

Comment 10

17 years ago
To test it, go to a Linux machine, open a web page select print, the print
dialog comes up, now click in the browser contents. If the print dialogs hides,
you see the bug. If the print dialog stays on top of the browser window, it is
fixed.

I see already more code duplication in these four files, for example the
function GetPageDimensions. I suggest to make the wish for reducing code
duplication a separate bug, to speed up landing of this fix. But feel free to
attach a modified patch! However, I already asked for superreview, and this work
will be useless when we attach a new patch. So personally I'd prefer a new bug.

Comment 11

17 years ago
sr=attinasi under the assumption that the test suggested by Kai has actually
been performed (I do not have time to patch/build/test this change myself, sorry).

Comment 12

17 years ago
a=asa on behalf of drivers@mozilla.org
(Reporter)

Comment 13

17 years ago
Patch checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 14

17 years ago
verified in 10/2 linux build.

looks like it works now....I simply print any page and then
give the browser window focus, the print dialog stays on top
like it should.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.