Intermittent browser_workerAPI.js | application terminated with exit code 2816 | application crashed [@ free]

RESOLVED DUPLICATE of bug 932851

Status

()

Core
DOM
--
critical
RESOLVED DUPLICATE of bug 932851
5 years ago
5 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({crash, intermittent-failure})

Trunk
x86
Linux
crash, intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=30281741&tree=Mozilla-Aurora

Ubuntu VM 12.04 mozilla-aurora pgo test mochitest-browser-chrome on 2013-11-07 09:51:29 PST for push 8da8761dab7d
slave: tst-linux32-ec2-375

10:27:47     INFO -  TEST-START | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js
10:27:47     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | sub-test testProfile starting
10:27:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | Console message: [JavaScript Error: "The character encoding of the plain text document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the file needs to be declared in the transfer protocol or file needs to use a byte order mark as an encoding signature." {file: "http://example.com/browser/toolkit/components/social/test/browser/worker_social.js" line: 0}]
10:27:48     INFO -  TEST-PASS | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | update of profile from our provider
10:27:48     INFO -  TEST-PASS | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | portrait is set
10:27:48     INFO -  TEST-PASS | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | userName is set
10:27:48     INFO -  TEST-PASS | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | displayName is set
10:27:48     INFO -  TEST-PASS | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | profileURL is set
10:27:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | sub-test testProfile complete
10:27:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | sub-test testAmbientNotification starting
10:27:48     INFO -  TEST-PASS | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | update is from our provider
10:27:48     INFO -  TEST-PASS | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | ambientNotification reflected
10:27:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | sub-test testAmbientNotification complete
10:27:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | sub-test testProfileCleared starting
10:27:48     INFO -  TEST-PASS | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | update of profile from our provider
10:27:48     INFO -  TEST-PASS | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | profile was cleared by empty username
10:27:48     INFO -  TEST-PASS | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | icons were cleared by empty username
10:27:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | sub-test testProfileCleared complete
10:27:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | sub-test testNoCookies starting
10:27:49  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | application terminated with exit code 2816
10:27:49     INFO -  INFO | runtests.py | Application ran for: 0:30:29.341382
10:27:49     INFO -  INFO | zombiecheck | Reading PID log: /tmp/tmpgWkBhzpidlog
10:27:49     INFO -  ==> process 2237 launched child process 2281
10:27:49     INFO -  ==> process 2237 launched child process 2288
10:27:49     INFO -  ==> process 2237 launched child process 2341
10:27:49     INFO -  ==> process 2237 launched child process 2345
10:27:49     INFO -  ==> process 2237 launched child process 2349
10:27:49     INFO -  ==> process 2237 launched child process 2353
10:27:49     INFO -  ==> process 2237 launched child process 2369
10:27:49     INFO -  ==> process 2237 launched child process 2391
10:27:49     INFO -  ==> process 2237 launched child process 2406
10:27:49     INFO -  ==> process 2237 launched child process 2420
10:27:49     INFO -  ==> process 2237 launched child process 2434
10:27:49     INFO -  ==> process 2237 launched child process 2445
10:27:49     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2281
10:27:49     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2288
10:27:49     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2341
10:27:49     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2345
10:27:49     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2349
10:27:49     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2353
10:27:49     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2369
10:27:49     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2391
10:27:49     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2406
10:27:49     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2420
10:27:49     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2434
10:27:49     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2445
10:27:49     INFO -  mozcrash INFO | Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-aurora-linux/1383837670/firefox-27.0a2.en-US.linux-i686.crashreporter-symbols.zip
10:28:19  WARNING -  PROCESS-CRASH | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_workerAPI.js | application crashed [@ free]
10:28:19     INFO -  Crash dump filename: /tmp/tmp5_YcF7/minidumps/5c677457-2343-d1f1-51aa694b-50e5ce5c.dmp
10:28:19     INFO -  Operating system: Linux
10:28:19     INFO -                    0.0.0 Linux 3.2.0-23-generic-pae #36-Ubuntu SMP Tue Apr 10 22:19:09 UTC 2012 i686
10:28:19     INFO -  CPU: x86
10:28:19     INFO -       GenuineIntel family 6 model 45 stepping 7
10:28:19     INFO -       1 CPU
10:28:19     INFO -  Crash reason:  SIGSEGV
10:28:19     INFO -  Crash address: 0x0
10:28:19     INFO -  Thread 0 (crashed)
10:28:19     INFO -   0  firefox!free [jemalloc.c:8da8761dab7d : 4636 + 0x0]
10:28:19     INFO -      eip = 0x080609b4   esp = 0xbfdf5020   ebp = 0xbfdf5128   ebx = 0x0806c9d0
10:28:19     INFO -      esi = 0xbfdf50eb   edi = 0x0000002e   eax = 0x0000002e   ecx = 0x0000002e
10:28:19     INFO -      edx = 0x00000000   efl = 0x00010246
10:28:19     INFO -      Found by: given as instruction pointer in context
10:28:19     INFO -   1  libxul.so!js::Discard [Utility.h:8da8761dab7d : 165 + 0x4]
10:28:19     INFO -      eip = 0xb5f25914   esp = 0xbfdf5070   ebp = 0xbfdf5128   ebx = 0xb6ddd1c0
10:28:19     INFO -      esi = 0xbfdf50eb   edi = 0xbfdf6150
10:28:19     INFO -      Found by: call frame info
10:28:19     INFO -   2  libxul.so!js::SCOutput::~SCOutput() [StructuredClone.cpp:8da8761dab7d : 550 + 0x7]
10:28:19     INFO -      eip = 0xb5f25b9c   esp = 0xbfdf50a0   ebp = 0xbfdf51d0   ebx = 0xb6ddd1c0
10:28:19     INFO -      esi = 0xbfdf50ec   edi = 0xbfdf50ec
10:28:19     INFO -      Found by: call frame info
10:28:19     INFO -   3  libxul.so!js::WriteStructuredClone(JSContext*, JS::Handle<JS::Value>, unsigned long long**, unsigned int*, JSStructuredCloneCallbacks const*, void*, JS::Value) [StructuredClone.cpp:8da8761dab7d : 322 + 0x13]
10:28:19     INFO -      eip = 0xb5f289a6   esp = 0xbfdf50c0   ebp = 0xbfdf51d0   ebx = 0xb6ddd1c0
10:28:19     INFO -      esi = 0xbfdf5108   edi = 0xbfdf50ec
10:28:19     INFO -      Found by: call frame info
10:28:19     INFO -   4  libxul.so!JS_WriteStructuredClone(JSContext*, JS::Handle<JS::Value>, unsigned long long**, unsigned int*, JSStructuredCloneCallbacks const*, void*, JS::Handle<JS::Value>) [StructuredClone.cpp:8da8761dab7d : 1585 + 0x38]
10:28:19     INFO -      eip = 0xb5f28a3f   esp = 0xbfdf5250   ebp = 0xbfdf530c   ebx = 0xb6ddd1c0
10:28:19     INFO -      esi = 0xbfdf52f8   edi = 0xaf09a020
10:28:19     INFO -      Found by: call frame info
10:28:19     INFO -   5  libxul.so!JSAutoStructuredCloneBuffer::write(JSContext*, JS::Handle<JS::Value>, JS::Handle<JS::Value>, JSStructuredCloneCallbacks const*, void*) [StructuredClone.cpp:8da8761dab7d : 1729 + 0x36]
10:28:19     INFO -      eip = 0xb5f28a97   esp = 0xbfdf5290   ebp = 0xbfdf530c   ebx = 0xb6ddd1c0
10:28:19     INFO -      esi = 0xbfdf530c   edi = 0x7f5f0190
10:28:19     INFO -      Found by: call frame info
10:28:19     INFO -   6  libxul.so!nsGlobalWindow::PostMessageMoz(JSContext*, JS::Handle<JS::Value>, nsAString_internal const&, JS::Handle<JS::Value>, mozilla::ErrorResult&) [nsGlobalWindow.cpp:8da8761dab7d : 7804 + 0x1b]
10:28:19     INFO -      eip = 0xb4e31dff   esp = 0xbfdf52c0   ebp = 0xbfdf530c   ebx = 0xb6ddd1c0
10:28:19     INFO -      esi = 0x74b1c220   edi = 0x7f5f0190
10:28:19     INFO -      Found by: call frame info
10:28:19     INFO -   7  libxul.so!nsGlobalWindow::PostMessageMoz(JSContext*, JS::Handle<JS::Value>, nsAString_internal const&, JS::Handle<JS::Value>, mozilla::ErrorResult&) [nsGlobalWindow.cpp:8da8761dab7d : 7701 + 0x37]
10:28:19     INFO -      eip = 0xb4e31a42   esp = 0xbfdf5420   ebp = 0xb72e8a58   ebx = 0xb6ddd1c0
10:28:19     INFO -      esi = 0x74b1ad80   edi = 0xbfdf55a0
10:28:19     INFO -      Found by: call frame info
10:28:19     INFO -   8  libxul.so!nsGlobalWindow::PostMessageMoz(JS::Value const&, nsAString_internal const&, JS::Value const&, JSContext*) [nsGlobalWindow.cpp:8da8761dab7d : 7844 + 0x23]
10:28:19     INFO -      eip = 0xb4e31f1d   esp = 0xbfdf5580   ebp = 0xbfdf5608   ebx = 0xb6ddd1c0
10:28:19     INFO -      esi = 0x00000004   edi = 0xbfdf569c
10:28:19     INFO -      Found by: call frame info
The social API does not use a "real" worker.
Component: DOM: Workers → DOM
(Reporter)

Updated

5 years ago
See Also: → bug 933948
(Reporter)

Updated

5 years ago
See Also: → bug 937346
(Reporter)

Updated

5 years ago
See Also: → bug 938729
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 932851
You need to log in before you can comment on or make changes to this bug.