Closed Bug 936192 Opened 6 years ago Closed 6 years ago

Misplaced icon for multiday events in the today pane

Categories

(Calendar :: Lightning Only, defect, trivial)

Lightning 2.8
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bv1578, Assigned: bv1578)

References

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

Steps to reproduce:

- create an event with more than one day duration which overlaps today, tomorrow or some day of the "soon" section in the today-pane;

-> the icon that shows the "start", "continue" or "end" condition of the event for a given day section in the agenda is misplaced.


This bug is caused by the patch for bug 781424.
Attached patch Patch - v1 (obsolete) — Splinter Review
The patch should fix. 
I've used a different margin (0.6em) for the agenda-multiDayEvent-image when is displayed an all-day event. With that margin the icon is placed vertically in the middle for all-day event without wrapped text (only one line).
Attachment #828896 - Flags: review?(Mozilla)
Status: NEW → ASSIGNED
Comment on attachment 828896 [details] [diff] [review]
Patch - v1

Patch works well in Windows & Linux (Ubuntu)

Only thing I noticed is, that the Text shows slightly lower than the images with larger fonts selected in the OS.
This however is neither caused by this patch nor by bug 781424. Also Lightning has various display-flaws using larger fonts - so maybe that's work for another bug.

r=markus
Attachment #828896 - Flags: review?(Mozilla) → review+
Setting Milestone to 2.8, since bug 781424 was checked in there.
Target Milestone: --- → 2.8
Attached patch patch - v2Splinter Review
This patch is a compromise, it lowers the icons a bit for small characters but without damaging too much the look and for large characters it seems still acceptable (though not perfect).
In the next screenshoot there is a comparison between this patch and the previous with different characters size on Windows.

If you want to give it a try ...


Fixing for all character size without inserting other boxes or a "center" property somewhere could be a bit annoying.
Attachment #829357 - Flags: review?(Markus)
(In reply to Markus Adrario [:Taraman] from comment #3)
> Setting Milestone to 2.8, since bug 781424 was checked in there.

You should request approval for beta and aurora if it should be fixed in 2.8.
Comment on attachment 829357 [details] [diff] [review]
patch - v2

Review of attachment 829357 [details] [diff] [review]:
-----------------------------------------------------------------

This looks much better.
Thanks.

r=markus
Attachment #829357 - Flags: review?(Markus) → review+
Attachment #829357 - Flags: approval-calendar-beta?(philipp)
Attachment #829357 - Flags: approval-calendar-aurora?(philipp)
Pushed on comm-central

https://hg.mozilla.org/comm-central/rev/c295fd48b308
Attachment #828896 - Attachment is obsolete: true
Attachment #829357 - Flags: approval-calendar-beta?(philipp)
Attachment #829357 - Flags: approval-calendar-beta+
Attachment #829357 - Flags: approval-calendar-aurora?(philipp)
Attachment #829357 - Flags: approval-calendar-aurora+
pushed to comm-aurora and comm-beta
http://hg.mozilla.org/releases/comm-aurora/rev/ab379da6669c
http://hg.mozilla.org/releases/comm-beta/rev/f6cf34c9ec23
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.