Updated Yahoo Logo on desktop search drop-down

RESOLVED FIXED in Firefox 28

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jnagel, Assigned: mconnor)

Tracking

unspecified
Firefox 30
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox28 fixed, firefox29 fixed, firefox30 fixed)

Details

(Whiteboard: [qa-])

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 828899 [details]
Yahoo! Final_Favicon.png

Yahoo has s recently updated their Logo and request that we update the search drop-down with the new logo for Desktop & Mobile.  Due to some confusion on a localization bug, this should have been prioritized back in Sept.  

I would appreciate any support to expedite this as quickly as possible!

Thanks,
Joanne
(Assignee)

Comment 1

5 years ago
As a data: URL

data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8%2F9hAAAACXBIWXMAAAsTAAALEwEAmpwYAAAKT2lDQ1BQaG90b3Nob3AgSUNDIHByb2ZpbGUAAHjanVNnVFPpFj333vRCS4iAlEtvUhUIIFJCi4AUkSYqIQkQSoghodkVUcERRUUEG8igiAOOjoCMFVEsDIoK2AfkIaKOg6OIisr74Xuja9a89%2BbN%2FrXXPues852zzwfACAyWSDNRNYAMqUIeEeCDx8TG4eQuQIEKJHAAEAizZCFz%2FSMBAPh%2BPDwrIsAHvgABeNMLCADATZvAMByH%2Fw%2FqQplcAYCEAcB0kThLCIAUAEB6jkKmAEBGAYCdmCZTAKAEAGDLY2LjAFAtAGAnf%2BbTAICd%2BJl7AQBblCEVAaCRACATZYhEAGg7AKzPVopFAFgwABRmS8Q5ANgtADBJV2ZIALC3AMDOEAuyAAgMADBRiIUpAAR7AGDIIyN4AISZABRG8lc88SuuEOcqAAB4mbI8uSQ5RYFbCC1xB1dXLh4ozkkXKxQ2YQJhmkAuwnmZGTKBNA%2Fg88wAAKCRFRHgg%2FP9eM4Ors7ONo62Dl8t6r8G%2FyJiYuP%2B5c%2BrcEAAAOF0ftH%2BLC%2BzGoA7BoBt%2FqIl7gRoXgugdfeLZrIPQLUAoOnaV%2FNw%2BH48PEWhkLnZ2eXk5NhKxEJbYcpXff5nwl%2FAV%2F1s%2BX48%2FPf14L7iJIEyXYFHBPjgwsz0TKUcz5IJhGLc5o9H%2FLcL%2F%2Fwd0yLESWK5WCoU41EScY5EmozzMqUiiUKSKcUl0v9k4t8s%2BwM%2B3zUAsGo%2BAXuRLahdYwP2SycQWHTA4vcAAPK7b8HUKAgDgGiD4c93%2F%2B8%2F%2FUegJQCAZkmScQAAXkQkLlTKsz%2FHCAAARKCBKrBBG%2FTBGCzABhzBBdzBC%2FxgNoRCJMTCQhBCCmSAHHJgKayCQiiGzbAdKmAv1EAdNMBRaIaTcA4uwlW4Dj1wD%2FphCJ7BKLyBCQRByAgTYSHaiAFiilgjjggXmYX4IcFIBBKLJCDJiBRRIkuRNUgxUopUIFVIHfI9cgI5h1xGupE7yAAygvyGvEcxlIGyUT3UDLVDuag3GoRGogvQZHQxmo8WoJvQcrQaPYw2oefQq2gP2o8%2BQ8cwwOgYBzPEbDAuxsNCsTgsCZNjy7EirAyrxhqwVqwDu4n1Y8%2BxdwQSgUXACTYEd0IgYR5BSFhMWE7YSKggHCQ0EdoJNwkDhFHCJyKTqEu0JroR%2BcQYYjIxh1hILCPWEo8TLxB7iEPENyQSiUMyJ7mQAkmxpFTSEtJG0m5SI%2BksqZs0SBojk8naZGuyBzmULCAryIXkneTD5DPkG%2BQh8lsKnWJAcaT4U%2BIoUspqShnlEOU05QZlmDJBVaOaUt2ooVQRNY9aQq2htlKvUYeoEzR1mjnNgxZJS6WtopXTGmgXaPdpr%2Bh0uhHdlR5Ol9BX0svpR%2BiX6AP0dwwNhhWDx4hnKBmbGAcYZxl3GK%2BYTKYZ04sZx1QwNzHrmOeZD5lvVVgqtip8FZHKCpVKlSaVGyovVKmqpqreqgtV81XLVI%2BpXlN9rkZVM1PjqQnUlqtVqp1Q61MbU2epO6iHqmeob1Q%2FpH5Z%2FYkGWcNMw09DpFGgsV%2FjvMYgC2MZs3gsIWsNq4Z1gTXEJrHN2Xx2KruY%2FR27iz2qqaE5QzNKM1ezUvOUZj8H45hx%2BJx0TgnnKKeX836K3hTvKeIpG6Y0TLkxZVxrqpaXllirSKtRq0frvTau7aedpr1Fu1n7gQ5Bx0onXCdHZ4%2FOBZ3nU9lT3acKpxZNPTr1ri6qa6UbobtEd79up%2B6Ynr5egJ5Mb6feeb3n%2Bhx9L%2F1U%2FW36p%2FVHDFgGswwkBtsMzhg8xTVxbzwdL8fb8VFDXcNAQ6VhlWGX4YSRudE8o9VGjUYPjGnGXOMk423GbcajJgYmISZLTepN7ppSTbmmKaY7TDtMx83MzaLN1pk1mz0x1zLnm%2Beb15vft2BaeFostqi2uGVJsuRaplnutrxuhVo5WaVYVVpds0atna0l1rutu6cRp7lOk06rntZnw7Dxtsm2qbcZsOXYBtuutm22fWFnYhdnt8Wuw%2B6TvZN9un2N%2FT0HDYfZDqsdWh1%2Bc7RyFDpWOt6azpzuP33F9JbpL2dYzxDP2DPjthPLKcRpnVOb00dnF2e5c4PziIuJS4LLLpc%2BLpsbxt3IveRKdPVxXeF60vWdm7Obwu2o26%2FuNu5p7ofcn8w0nymeWTNz0MPIQ%2BBR5dE%2FC5%2BVMGvfrH5PQ0%2BBZ7XnIy9jL5FXrdewt6V3qvdh7xc%2B9j5yn%2BM%2B4zw33jLeWV%2FMN8C3yLfLT8Nvnl%2BF30N%2FI%2F9k%2F3r%2F0QCngCUBZwOJgUGBWwL7%2BHp8Ib%2BOPzrbZfay2e1BjKC5QRVBj4KtguXBrSFoyOyQrSH355jOkc5pDoVQfujW0Adh5mGLw34MJ4WHhVeGP45wiFga0TGXNXfR3ENz30T6RJZE3ptnMU85ry1KNSo%2Bqi5qPNo3ujS6P8YuZlnM1VidWElsSxw5LiquNm5svt%2F87fOH4p3iC%2BN7F5gvyF1weaHOwvSFpxapLhIsOpZATIhOOJTwQRAqqBaMJfITdyWOCnnCHcJnIi%2FRNtGI2ENcKh5O8kgqTXqS7JG8NXkkxTOlLOW5hCepkLxMDUzdmzqeFpp2IG0yPTq9MYOSkZBxQqohTZO2Z%2Bpn5mZ2y6xlhbL%2BxW6Lty8elQfJa7OQrAVZLQq2QqboVFoo1yoHsmdlV2a%2FzYnKOZarnivN7cyzytuQN5zvn%2F%2FtEsIS4ZK2pYZLVy0dWOa9rGo5sjxxedsK4xUFK4ZWBqw8uIq2Km3VT6vtV5eufr0mek1rgV7ByoLBtQFr6wtVCuWFfevc1%2B1dT1gvWd%2B1YfqGnRs%2BFYmKrhTbF5cVf9go3HjlG4dvyr%2BZ3JS0qavEuWTPZtJm6ebeLZ5bDpaql%2BaXDm4N2dq0Dd9WtO319kXbL5fNKNu7g7ZDuaO%2FPLi8ZafJzs07P1SkVPRU%2BlQ27tLdtWHX%2BG7R7ht7vPY07NXbW7z3%2FT7JvttVAVVN1WbVZftJ%2B7P3P66Jqun4lvttXa1ObXHtxwPSA%2F0HIw6217nU1R3SPVRSj9Yr60cOxx%2B%2B%2Fp3vdy0NNg1VjZzG4iNwRHnk6fcJ3%2FceDTradox7rOEH0x92HWcdL2pCmvKaRptTmvtbYlu6T8w%2B0dbq3nr8R9sfD5w0PFl5SvNUyWna6YLTk2fyz4ydlZ19fi753GDborZ752PO32oPb%2B%2B6EHTh0kX%2Fi%2Bc7vDvOXPK4dPKy2%2BUTV7hXmq86X23qdOo8%2FpPTT8e7nLuarrlca7nuer21e2b36RueN87d9L158Rb%2F1tWeOT3dvfN6b%2FfF9%2FXfFt1%2Bcif9zsu72Xcn7q28T7xf9EDtQdlD3YfVP1v%2B3Njv3H9qwHeg89HcR%2FcGhYPP%2FpH1jw9DBY%2BZj8uGDYbrnjg%2BOTniP3L96fynQ89kzyaeF%2F6i%2FsuuFxYvfvjV69fO0ZjRoZfyl5O%2FbXyl%2FerA6xmv28bCxh6%2ByXgzMV70VvvtwXfcdx3vo98PT%2BR8IH8o%2F2j5sfVT0Kf7kxmTk%2F8EA5jz%2FGMzLdsAAAAgY0hSTQAAeiUAAICDAAD5%2FwAAgOkAAHUwAADqYAAAOpgAABdvkl%2FFRgAAAmdJREFUeNps0j%2BInGUUxeHnvt%2FMTpKdrBuXEMVSSCGmipCAsU5KiY0IaSRWIqKdhdWChUKqFFaRKAgWEku3XzsVRVhiLKJFBP9ExMnuzsz3ve%2B12DVpPN29HA6H371x1hsZCmI7dDdX4vhWiSMzSBUidJA159M%2BZxdTvUqeT82os2piw9jRC6OVuLDsF6ql%2F9OKNUdsIPT2LPxl1Jk46qRjccL1nRc89fQJL44%2Fl1JGE4IMpRS35pfd3bnvrWe%2Fsue%2Bwa5CZ2zVpHvMh5s74Iv%2BJavllNV4wrE4ZdqdcmtxmeCja7dNyroVx9EpJJG0zi%2Bfrtj57mfw%2FGsbRjE2irGzr6yDT97%2F1t2PV4QiY0Aq1FkXnVaWqt575%2B6B168%2FIw%2FD375xBmy9O9ei18rSKMaos5LqbOEf1cIQe4aYu7F5G1zaPOm5K2syubF52xBzQ%2BwbzC3MpDqLc975cb2cPn2kW9PFRIlQuuKz3UsP6Wfy8vRLrTYt05Bzizrzd7tzpxzcezBYqOaquSH3XHv1h4cBH1z53pD7qv1Dz0IawCjldDBXckRUBUXn6%2B2fcEa29M32HdWgqRpq9gb7Uk5HKdcGS519LceKEI3h1%2FlBfez%2B%2BUBrKTO1TKk36KVcG9GmNReGVpRStUglQx0ClBL6YY9M7ZBHa72aC7TpKDUtl5ZBySJa6CJMuycPGrQ0iXUP2j01HbSQWi6lZpSaakGrWgmSoWPy%2BB8HBCP0G79b%2FLYr2yHVRtVLTZz1ZhZjxKE%2FZfw3PVI6eNjMeLhpeiOaZoHYxs2i26KbHSamR1mZ6rSpF3GVPA%2F%2FDgDwDEOJA%2FCitQAAAABJRU5ErkJggg%3D%3D
(Assignee)

Updated

5 years ago
Duplicate of this bug: 925037
(Assignee)

Comment 3

5 years ago
Currently waiting on Yahoo! to confirm which locales should have the new icon (some locales are still using the red favicon, such as Japan: http://www.yahoo.co.jp/).
(In reply to Mike Connor [:mconnor] from comment #3)
> Currently waiting on Yahoo! to confirm which locales should have the new
> icon (some locales are still using the red favicon, such as Japan:
> http://www.yahoo.co.jp/).

Good to know. 

It would probably be easier to get the list of locales who shouldn't get the new icon (I found only Japan so far).
Blocks: 939834
Created attachment 8333994 [details]
Encoded PNG (shorter)

I wonder if we should use a data uri without % (about 10% shorter).

Note also that there's a new funny version of the image on trunk for Metro (74px, standard icon + purple canvas).
(Assignee)

Comment 6

5 years ago
+1 for the encoded PNG.  Is there a good tool for doing those conversions?

Word from Yahoo! is Japan (so ja-JP and ja-JP-mac) and Australia (we don't produce en-GB-au builds, though I sort of wish we did) are the only locales that still use the old branding.  Is there a good way to do this mass change? (I know we discussed briefly on Friday, but I've lost that scrollback)
I usually rely on this website for conversion
http://webcodertools.com/imagetobase64converter

Consider that % breaks the image on mobile, meaning the searchplugin will lose its icon.

Unfortunately there's no tool to easy do that for all locales, but lucky you I'm actually doing it in bug 939834 (on Aurora and Central, we're too close to end of the cycle to touch Beta). 
All "official" (requested) locales on mobile already have the right icon on all branches. 

Once you fix en-US, a lot of locales will get automatically the new icon on all branches. On a side note, I think we need to fix Bing as well.
Replacement has been completed on all locales (mobile, desktop) on Aurora. At this point we need the updated en-US to have all icons in place (excluding Japanese).
(Reporter)

Comment 9

5 years ago
Mike - any update on getting this lifted? It's almost a month and I need to get back to Yahoo with a status...   Thanks, Joanne
(Reporter)

Updated

5 years ago
Flags: needinfo?(mconnor)
(Assignee)

Comment 10

5 years ago
Created attachment 8343775 [details] [diff] [review]
yahooIconUS

Updated icon for en-US.
Attachment #8343775 - Flags: review?(jaws)
Flags: needinfo?(mconnor)
Comment on attachment 8343775 [details] [diff] [review]
yahooIconUS

Review of attachment 8343775 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me
Attachment #8343775 - Flags: review?(jaws) → review+
Shouldn't there be an update for the HiDPI icon as well?
Why does the % character break the image on mobile?
Flags: needinfo?(francesco.lodolo)
(Assignee)

Comment 14

5 years ago
There should, but really that's a big project we need to tackle more consistently.  This is minimum stuff, will do a pass of "get 32x32 icons from partners" as a followup.
Comment on attachment 8343775 [details] [diff] [review]
yahooIconUS

Flipping review flag, as this need to match up with the way that bug 795495 handled HiDPI icons, and there might be a test that needs to be updated.
Attachment #8343775 - Flags: review+ → review-
(In reply to Jared Wein [:jaws] from comment #13)
> Why does the % character break the image on mobile?

No idea about the reason, I only know because I found the image broken in 3 or 4 locales.
Bug 892924 was filed to fix it.
Flags: needinfo?(francesco.lodolo)
(Assignee)

Comment 17

5 years ago
Created attachment 8343943 [details] [diff] [review]
yahooIconUS

hiDPI for small icon.  Will wait on Yahoo! for a 74x74 icon since I can't seem to find one remotely big enough to not look terrible.
Attachment #8343775 - Attachment is obsolete: true
Attachment #8343943 - Flags: review?(gavin.sharp)
Comment on attachment 8343943 [details] [diff] [review]
yahooIconUS

(I assume you tested this doesn't regress retina appearance)
Attachment #8343943 - Flags: review?(gavin.sharp) → review+
Since you're touching metro here too, CCing bbondy/jimm just as a heads up.
https://hg.mozilla.org/mozilla-central/rev/d46b56542e2e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
(Assignee)

Comment 21

5 years ago
Gah, forgot [leave open] here.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 22

5 years ago
Comment on attachment 8343943 [details] [diff] [review]
yahooIconUS

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Out of date icon
Testing completed (on m-c, etc.): baked for six weeks
Risk to taking this patch (and alternatives if risky): effectively nil
String or IDL/UUID changes made by this patch: none

Yahoo would like to see this fixed ASAP.
Attachment #8343943 - Flags: approval-mozilla-aurora?
Attachment #8343943 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 23

5 years ago
Created attachment 8368274 [details] [diff] [review]
yahooIcon2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: ugly ugly icon on Metro
Testing completed (on m-c, etc.): seems to work fine
Risk to taking this patch (and alternatives if risky): almost nil
String or IDL/UUID changes made by this patch:none

The Metro version.  Should be a straightforward image update, I'd like to at least get this on Aurora to match the other patch.
Attachment #8368274 - Flags: review?(gavin.sharp)
Attachment #8368274 - Flags: approval-mozilla-aurora?
Attachment #8368274 - Attachment is patch: true
Attachment #8368274 - Flags: review?(gavin.sharp) → review?(mbrubeck)
Attachment #8368274 - Flags: review?(mbrubeck) → review+
Attachment #8368274 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Created attachment 8369892 [details]
yahoo images.html

I must admit that I'm lost.

I see approval for mozilla-aurora but no reference to landing. So I checked the repositories (see attached file):
* there's no reference here but apparently this patch landed on aurora last cycle and it's now on beta
http://hg.mozilla.org/releases/mozilla-beta/rev/79f8a9a64075
* this patch never landed on central, so we are now displaying the wrong image on both central and aurora

I filed bug 967388 to track l10n updates.
status-firefox29: --- → fixed
Target Milestone: Firefox 29 → Firefox 30
status-firefox28: --- → fixed
status-firefox29: fixed → ---
(Assignee)

Comment 25

5 years ago
Yeah, I landed on aurora, and then inbound was closed until I ran out of time to land there.  I'll land on inbound and aurora (again) shortly.
Whiteboard: [qa-]
status-firefox29: --- → fixed
status-firefox30: --- → fixed
https://hg.mozilla.org/mozilla-central/rev/bbc51e586d3f
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.