a keyboard key for restart Firefox

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: saad.shamsaee, Unassigned)

Tracking

26 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131104182142

Steps to reproduce:

many times i install a extension, firefox should restart, but i want close tabs before restart.


Actual results:

but when i close tabs, restart button will be hidden.


Expected results:

firefox must have a restart keyboard key. like Shift+Esc .

Comment 1

5 years ago
Niche feature, it could be covered by add-on, like https://addons.mozilla.org/en-US/firefox/addon/quickrestart/
In addition, see bug 420688.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Component: Untriaged → Keyboard Navigation
Resolution: --- → WONTFIX
(Reporter)

Comment 2

5 years ago
oh my god! 
at least do that when a extension installed and firefox show restart button, it not remove by click on tabs.
(Reporter)

Comment 3

5 years ago
do you knew my purpose?
(Reporter)

Comment 4

5 years ago
This extension is better:
Restartless Restart: https://addons.mozilla.org/firefox/addon/restartless-restart/

Comment 5

5 years ago
This is one particular case where an extension won't do the job. One of the reasons to restart is if you're in safe mode and you want to switch back to normal mode; an extension will be useless for this because safe mode will disable it.
You need to log in before you can comment on or make changes to this bug.