Closed Bug 936359 Opened 6 years ago Closed 6 years ago

Honor the DEBUG flag in RilContentHelper.js

Categories

(Firefox OS Graveyard :: RIL, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox25 unaffected, firefox26 unaffected, firefox27 fixed, firefox28 fixed, b2g18 unaffected, b2g-v1.1hd unaffected, b2g-v1.2 unaffected)

RESOLVED FIXED
Tracking Status
firefox25 --- unaffected
firefox26 --- unaffected
firefox27 --- fixed
firefox28 --- fixed
b2g18 --- unaffected
b2g-v1.1hd --- unaffected
b2g-v1.2 --- unaffected

People

(Reporter: fabrice, Assigned: vicamo)

Details

Attachments

(2 files, 1 obsolete file)

This is spamming logcat like crazy.
Attached patch ril-debug.patch (obsolete) — Splinter Review
Attachment #829097 - Flags: review?(vyang)
Attached patch patchSplinter Review
Hi Fabrice, I rewrite your patch to guard all debug lines with DEBUG instead.  Hope you won't mind.  Just don't want to waste CPU cycles in preparing debug messages that aren't printed.  Same guideline is applied in other RIL components.
Assignee: fabrice → vyang
Attachment #829097 - Attachment is obsolete: true
Attachment #829097 - Flags: review?(vyang)
Attachment #829119 - Flags: review?(htsai)
Comment on attachment 829119 [details] [diff] [review]
patch

Review of attachment 829119 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.
Attachment #829119 - Flags: review?(htsai) → review+
Comment on attachment 829119 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 926302
User impact if declined: all internal B2G RIL messages are output to console by default.  Some of them might carry user secrets.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Guard all debug messages with a default disabled preference only.
String or IDL/UUID changes made by this patch:
Attachment #829119 - Flags: approval-mozilla-aurora?
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #5)
> [Approval Request Comment]
> Bug caused by (feature/regressing bug #): bug 926302

Bug 926302 is in aurora so I raised this approval request.  It's not in b2g26_v1_2 as current tip is http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/file/baad19cc5f1f/dom/system/gonk/RILContentHelper.js.
https://hg.mozilla.org/mozilla-central/rev/a70d9f8f0400
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Attachment #829119 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.