[Notification] Notification counter doesn't work correctly.

RESOLVED FIXED

Status

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: atsai, Assigned: gasolin)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:1.3+)

Details

(Whiteboard: [developer+])

Attachments

(3 attachments)

Posted image notification.png
The notification counter doesn't work correctly. There should be one notification in the list, and it shows "No notifications".

** The case is by the testing on Flatfish devices. It might not be able to reproduce on other mobile devices **

Gaia:     4a0bb67204572affcbf1afb384d2ffdc8261e977
Gecko:    e42dac2ae79959eadd8d832c715e430ada8d64cc
BuildID   20131108064537
Version   28.0a1
Ni? Francis to see if we need to fix the problem.
Flags: needinfo?(frlee)
Summary: [Flatfish] → [Flatfish][Notification] Notification counter doesn't work correctly.
Update correct commit number. Due to there's local patch for Flatfish now, the commit numbers in description didn't fulfill exist commit numbers.

GECKO_REV=33e7bec8e5daa5acb2be3c4fb1deca3eade0d142
GAIA_REV=b4e34df2b2e6249723d239d90f8cf6e4c769a6bc
GECKO_BRANCH=mozillaorg/master
GAIA_BRANCH=mozillaorg/master
BUILD_TAG=jenkins-B2G.master.flatfish-38
BuildID=20131108064537
functional fail, this is a must fix item. change it to developer+ and 1.3+
blocking-b2g: --- → 1.3+
Flags: needinfo?(frlee)
Whiteboard: [Flatfish][developer-] → [Flatfish][developer+]
I think it's not just a flatfish issue.

The cause is utility tray has many wildcard notifications, but gaia only count 'desktop-notifications-container' as real notifications. 

We need UX support to clarify which kind of items showed in Utility tray should count in the notifications

Wild card items are:

*update-manager-container (this case)
*emergency-callback-notification
*storage-watcher-container
*media-playback panel
*install-manager-notification-container
*bluetooth-transfer-status-list
*keyboard-show-ime-list
*media-recoding
Flags: needinfo?(mtsai)
Note that currently these wildcard items can't be cleaned via click 'Clear All' link at top right corner.
Can spot the same behavior on phone
Summary: [Flatfish][Notification] Notification counter doesn't work correctly. → [Notification] Notification counter doesn't work correctly.
Francis, since it's not flatfish-only issue, is it still developer+? To me, it's a wrong UI update, not functional fail.
Flags: needinfo?(frlee)
Evelyn, i just want to make sure this bug will be fixed for Flatfish. i will remove [Flatfish] whiteboard tag since its not only for Flatfish. are we targeting to fix it before 1.2 CS (1.3 FC)? if possible, could you please set a target milestone?
Flags: needinfo?(frlee)
Whiteboard: [Flatfish][developer+] → [developer+]
Mike, FYI 'storage-watcher-container' only shown when system has low Disk Space
Assignee: nobody → gasolin
Here's the mapping of the notifications : status bar icons
There're only 3 wildcard do not mapped to status bar yet

*update-manager-container
*storage-watcher-container
*keyboard-show-ime-list

*emergency-callback-notification ('emergency-cb-notification')
*media-playback panel ('playing')
*install-manager-notification-container ('system-downloads')
*bluetooth-transfer-status-list ('bluetooth-transferring')
*media-recoding ('recording')
More update:

The following handler will show statusbar notifications 

*update-manager-container
*storage-watcher-container

Only keyboard selector show nothing on statusbar

*keyboard-show-ime-list
per discussion offline with Mike & Harly, we'll always show 'Notifications' instead of 'No notification' even if there's no notification.
Attachment #832022 - Flags: review?(alive)
Please refer to comment 12 by Fred
Flags: needinfo?(mtsai)
Please refer to comment 12 by Fred
Attachment #832022 - Flags: review?(alive) → review+
merged to gaia-master https://github.com/mozilla-b2g/gaia/commit/d523f4bf685385b49e60cbc8ea5c15700a83dead

thanks!


request for a new keyboard visual indicator is filed in bug 939011
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.