Should be possible to print without including attachments

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Arne Kepp, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
This sort of goes for the whole mail system, but it is especially important for
printing; I often receive long tracebacks (bug reports) and I wish to print
these emails, but not neccesarily all the useless files people attach to them.

Unless there is an option that I have not yet figured out, I have to make a
guess at how many pages the email actually is and then specify which pages to
print out. This can be very time consuming. 

keywords: print excluding attachment
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

17 years ago
This is a mailnew feature.
Assignee: dcone → sspitzer
Component: Printing → Mail Window Front End
*** Bug 100265 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
Did somebody fix this?  I have a new bug (103812) where user is complaining that
mention of the attachments use to show up on the printout (builds 0.9.2) but no
longer do with builds 0.9.4.  I verified that when printing a message with an
attachment using 6.1rtm, we showed there was an attachment for the message.  We
displayed it in a  box with the attachment name, content type & content
encoding.  We no longer display this box on the printed message.  So this bug is
partially fixed meaning we don't display it at all, but we don't give the users
the option.  

Comment 4

17 years ago
I'm sorry, I read this wrong back on 12/03.  This bug is specifically for
attachments that are supported for inline reading (.jpg, .txt, .html .gif).  
Because they are displayed inline, we print it all and this still happens with
current builds (12-13-2001).  If we bring back the capabilities of turning off
View Attachments Inline (as in 4.x), then user will only see the mention of
attachment file name, not the attachment itself when printing or viewing.  Not
sure if this is what the reporter really wants but makes this bug no so bad if
we bring that option back (bug 112947).
(Reporter)

Comment 5

17 years ago
Sorry I didn't reply back 12.03;
Yes, I would like the possibility to turn off inline attachments. If this 
setting was global like in 4.x, ie same on the screen as on paper, then that 
would be fine. Ideally there should also be an option for this in the print 
dialogue, or an option to only print the text of a message or on a webpage.

I believe that this is not limited to attachments with extensions .jpg 
or .html, but that in fact all ASCII files will be shown inline. I am troubled 
by this because that includes the source code files I work with. Currently I 
am forced to estimate how many pages constitute the actual email and then only 
print those (or cut'n'paste to Word).

Updated

17 years ago
QA Contact: esther → trix

Comment 6

17 years ago
I filed bug 134492 about printing a list of attachments.
QA Contact: trix → stephend
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Comment 7

13 years ago
(In reply to comment #4)
> If we bring back the capabilities of turning off
> View Attachments Inline (as in 4.x), then user will only see the mention of
> attachment file name, not the attachment itself when printing or viewing. 
> Not sure if this is what the reporter really wants but makes this bug no so
> bad if we bring that option back[...].

View Attachments Inline has been reimplemented for quite some time.  With the option turned off, the message prints with a list of the attachments but not 
the attachments themselves.  Arne Kepp, is that solution sufficient?  If so, please mark this bug:   Resolved | WorksForMe

Comment 8

13 years ago
No response from reporter  =>  WFM
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.