[PP] When a mail server icon is selected, Messenger crashes/quits

VERIFIED FIXED in M8

Status

SeaMonkey
MailNews: Message Display
P1
critical
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: Katsuhiko Momoi, Assigned: Chris Waterson)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Fixed by Bienvenu's patch?)

(Reporter)

Description

19 years ago
** Observed with 7/7/99 Win32 build **

1. I start Messenger and see 3 mail server icons and 1
   NNTP server icon.
2. The next thing I do is click once on one of the server icon
   in the left pane. This leads to a sudden quit.
3. I've found that if I double-click on the same server icon,
   it works without a crash and displays all the folders I have
   on the server.

I have filed a few Talkback incident reports on this.
(Reporter)

Comment 1

19 years ago
Heer's an URL to one of the reports I sent to Talkback:

http://cyclone/reports/incidenttemplate.CFM?reportID=1099&style=0&tc=66&cp=3&ck1
=SUser+email+address&cd1=momoi%40netscape%2Ecom&ck2=SBug+ID&cd2=isNotNull&bbid=1
0874493

Its Incident ID is: 10874493
(Reporter)

Comment 2

19 years ago
For an easier access to the Talkback reports on this bug, you
can go here and select the links to this bug number:

http://cyclone/reports/reporttemplate.cfm?style=1&reportID=1099

Updated

19 years ago
QA Contact: lchiang → nbaca
Summary: When a mail server icon is selected, Messenger crashes/quits → [PP] When a mail server icon is selected, Messenger crashes/quits

Comment 3

19 years ago
nsSupportsArray::Clear
[d:\builds\seamonkey\mozilla\xpcom\ds\nsSupportsArray.cpp, line 309]
   nsSupportsArray::DeleteArray
[d:\builds\seamonkey\mozilla\xpcom\ds\nsSupportsArray.cpp, line 58]
   nsSupportsArray::`scalar deleting destructor'
   nsSupportsArray::Release
[d:\builds\seamonkey\mozilla\xpcom\ds\nsSupportsArray.cpp, line 53]
   StyleContextImpl::~StyleContextImpl
[d:\builds\seamonkey\mozilla\layout\base\src\nsStyleContext.cpp, line 1347]
   StyleContextImpl::`scalar deleting destructor'
   StyleContextImpl::Release
[d:\builds\seamonkey\mozilla\layout\base\src\nsStyleContext.cpp, line 1413]
   nsCOMPtr_base::~nsCOMPtr_base
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 26]
   nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 3885]
   nsCSSFrameConstructor::CreateTreeWidgetContent
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6291]
   nsTreeRowGroupFrame::GetNextFrameForReflow
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsTreeRowGroupFrame.cpp, line
884]
   nsTableRowGroupFrame::ReflowMappedChildren
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp,
line 505]
   nsTableRowGroupFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp,
line 1025]
   nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
408]
   nsTableFrame::ReflowMappedChildren
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 3820]
   nsTableFrame::ResizeReflowPass2
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 2892]
   nsTableFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 2592]
   nsTreeFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsTreeFrame.cpp, line 286]
   nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
408]
   nsTableOuterFrame::IR_InnerTableReflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line
567]
   nsTableOuterFrame::IR_TargetIsInnerTableFrame
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line
357]
   nsTableOuterFrame::IR_TargetIsChild
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line
347]
   nsTableOuterFrame::IncrementalReflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line
313]
   nsTableOuterFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line
961]
   nsBlockReflowContext::ReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line
228]
   nsBlockFrame::ReflowBlockFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2525]
   nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2016]
   nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1825]
   nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1200]
   nsBoxFrame::FlowChildAt
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 713]
   nsBoxFrame::FlowChildAt
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 685]
   nsBoxFrame::FlowChildren
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 412]
   nsBoxFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 285]
   nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
408]
   RootFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLFrame.cpp, line 245]
   nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
408]
   ViewportFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line 440]
   nsHTMLReflowCommand::Dispatch
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLReflowCommand.cpp, line
169]
   PresShell::ProcessReflowCommands
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 1323]
   PresShell::ExitReflowLock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 702]
   PresShell::ContentInserted
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 1749]
   XULDocumentImpl::ContentInserted
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 1949]
   RDFElementImpl::InsertChildAt
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFElement.cpp, line 1572]
   RDFGenericBuilderImpl::OnSetAttribute
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFGenericBuilder.cpp, line 1949]
   XULDocumentImpl::OnSetAttribute
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 3734]
   RDFElementImpl::SetAttribute
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFElement.cpp, line 916]
   ElementSetAttribute
[d:\builds\seamonkey\mozilla\dom\src\coreDOM\nsJSElement.cpp, line 265]
   js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 656]
   js_Interpret
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2218]
   js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 676]
   js_Interpret
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2218]
   js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 676]
   js_Interpret
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2218]
   js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 676]
   js_InternalCall
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 750]
   JS_CallFunctionValue
[d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 2645]
   nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 98]
   nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line
590]
   RDFElementImpl::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFElement.cpp, line 2351]
   RDFElementImpl::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFElement.cpp, line 2356]
   RDFElementImpl::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFElement.cpp, line 2356]
   RDFElementImpl::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFElement.cpp, line 2356]
   RDFElementImpl::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFElement.cpp, line 2356]
   RDFElementImpl::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsRDFElement.cpp, line 2356]


Ninoschka - can you try this on the other platforms?  Marking PP for now.

Comment 4

19 years ago
This looks like one of the stack traces in 9353.  David B, did you ever open up
a new bug or should this be it?

Comment 5

19 years ago
No, I didn't open a new bug. This stack trace looks a little bit more like the
second crash I was seeing, but the user actions are more like the first crash.
Let's leave this one open, but who should we assign it to? Obviously not Phil -
perhaps someone in layout? Or hyatt?

Updated

19 years ago
Assignee: phil → hyatt

Comment 6

19 years ago
I'll start off by reassigning to hyatt since he's been taking table/tree related
crashes that happen in our trees.  David, if it's not yours please reassign to
the layout team.

Comment 7

19 years ago
could this be a dup of 9354? I pulled after Troy's latest changes in
layout\html\style and one of my crashes has gone away.

Comment 8

19 years ago
Build 1999070708M8: Win32/NT4 and Linux/Rehat 5.2
Note: Will try another Mac build since the latest one failed to start.

I am not experiencing a crash when selecting the server icon once. I've tried
configurations with 2 imap, 2 pop and 1 news server. It crashed one time on NT4
but I have been unable to reproduce.
(Reporter)

Comment 9

19 years ago
It is true that the crash problem does not happen consistently.
I have 4 server icons and I tried clicking on each one of them once.
I carshed at the 4th one I tried. After that, it was easy to crash
just by picking one server. I also bring up my Messenger directly
via "apprunner -mail".

Comment 10

19 years ago
Have you rebuilt with Troy's change?

Comment 11

19 years ago
Build 1999070708M8: Mac 8.5.1

FYI: Unable to duplicate the crash by selecting the mail servers once. Tried a
prefs50.js with 4 mail server, 1 news server. Also tried one with 3 mail servers
and one news server.

Comment 12

19 years ago
1999070708M8: Win32/NT4, Linux/Redhat 5.2

I am able to duplicate a crash on NT4 and Linux with some regularity by single
selecting the servers fairly quickly. It seems to crash when an IMAP server is
selected (i.e. qatest22 and qatest33). I compared the TalkBack trace with the
one included in this bug and they do not match. Should I log a separate bug?

Comment 13

19 years ago
http://bugzilla.mozilla.org/show_bug.cgi?id=9398 was just reported.  Similar
steps, but the platform is Linux.  I cc'd hyatt on that bug.

We'd really like this bug to be fixed for M8, if possible, since it's quite easy
to run into this crash especially since our default prefs50.js shows a news and
an IMAP server in the folder pane.

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M8

Comment 14

19 years ago
Current status: I'm able to reproduce, and I've verified that this has nothing
to do with any of my recent changes.  The culprit therefore is something else
that was checked in over the last few days.

There are known problems with the tree widget and with Troy's recent checkin, so
I'll start by resolving those and see if that gets rid of this bug.

Comment 15

19 years ago
This class of bugs is making it really hard to solve other bugs since I keep
crashing while trying to work on them.  If you could look into this for M8, I'd
really appreciate this.

Updated

19 years ago
Priority: P3 → P1

Comment 16

19 years ago
setting p1

Comment 17

19 years ago
cc troy

Updated

19 years ago
Whiteboard: Fixed by Bienvenu's patch?
(Assignee)

Updated

19 years ago
Assignee: hyatt → waterson
Status: ASSIGNED → NEW
(Assignee)

Comment 18

19 years ago
Reassigning to self re: content model bustage.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 19

19 years ago
Fix checked in. Update mozilla/rdf/content/src/nsRDFTreeBuilder.cpp.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 20

19 years ago
OK using jul12 m8 build on NT 4.0.
Haven't seen any problem with other platforms either with the jul12 builds.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.