If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mouse arrow cursor flickers when Java applet redraws

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: bryanck, Assigned: av (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.3) Gecko/20010801
BuildID:    20011080110

When on a page with an applet that is redrawing, for instance a ticker tape
applet or scrolling headlines applet, and when you put the mouse cursor over the
menu, the cursor flickers.

Reproducible: Always
Steps to Reproduce:
1. Go to http://java.sun.com
2. This page should load an applet that scrolls some Java-related headlines.
3. Move the cursor over a menu item, such as "Bookmarks"
4. The cursor flickers, as if the menu is being unnecesarily repainted.

Actual Results:  The cursor flickers on and off.

Expected Results:  The cursor shouldn't flicker, it should remain a constant
image on the screen.
(Reporter)

Comment 1

16 years ago
The cursor flickers while over the applet too, so it doesn't seem to be a
menu-only problem.
(Reporter)

Comment 2

16 years ago
Actually, the cursor flickers anywhere in the Mozilla window, whenever it's an
arrow.
Component: XP Toolkit/Widgets: Menus → Plug-ins

Comment 3

16 years ago
Doesn't flicker for me on WinXP 2001080120, JRE 1.3.1, latest certified Matrox
drivers.  Using hardware to draw the mouse pointer.

Comment 4

16 years ago
I see this flicker for java.sun.com on win2k, and it happens anywhere in the 
window while it is the arrow cursor. Not a menu-specific bug, but I'm not 
really sure where this should go. [By the way, this does not flicker on Mac].
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Summary: Mouse cursor over menu flickers when Java applet redraws → Mouse arrow cursor flickers when Java applet redraws

Comment 5

16 years ago
Cursor flickers over applets only on win2k, winnt, and win98. It does not on
Linux with kernels 2.4.x. Perhaps repaint processes are handled in different
ways, e. g. in a thread of their own on Linux.
how did this get on my plate? --> plugins
Assignee: pinkerton → av
QA Contact: jrgm → shrir
(Assignee)

Comment 7

16 years ago
Shrirang, do you see this. I don't on my trunk build on NT40.

Comment 8

16 years ago
nope..works fine, I don't see the arrow pointer change or flicker on my NT 0817 
trunk build. Mine is a 450 mhz 128mb box.marking wfm.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 9

16 years ago
The original report is for Win2000. Would you please check it too just to make 
sure it is not _that_ platform specific?

Comment 10

16 years ago
i think this has gone away with time. I just retried this on a win 2000 with 
build 0817 and cannot reproduce.Bryan, pls retry and mark verif if u are 
satisfied.thx.

Comment 11

16 years ago
I see the mouse flicker at the URL.

Mozilla trunk 2001-12-12-03 on Win2000.
You need to log in before you can comment on or make changes to this bug.