[B2G][1.2][l10n][Keyboard] Multiple Languages - The symbol § is missing on the keyboard

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: KTucker, Assigned: reuben)

Tracking

({l12y})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: LocRun1.2)

Attachments

(3 attachments)

Created attachment 829396 [details]
2013-11-08-09-58-24.png

Description:
The symbol § is missing on the keyboard. 

Repro Steps:
1)  Updated Buri to Build ID: 20131108004004
2)  Tap on "Settings".
3)  Tap on "Keyboards". 
4)  Tap on "Selected keyboards".
5)  Tap on "Add more keyboards".
6)  Tap on "Portugues".
7)  Tap on the "Home" button on the phone and tap on the "Messages" icon.
8)  Tap on the "Compose New Message" icon.
9)  Tap on the "?123" button on the virtual keyboard.
10) Tap on the "Alt" button on the virtual keyboard.

Actual:
The § symbol is missing on the keyboard.

Expected:
The § symbol appears on the keyboard.

Environmental Variables
Device: Buri v 1.2.0 COM RIL
Build ID: 20131108004004
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/a886c641a306
Gaia: b401bfed469e1d6db24e910f78732bad32843e8a
Platform Version: 26.0
RIL Version: 01.02.00.019.102 

Notes:
Repro frequency: 100%
See attached: screenshot
Does this reproduce on 1.1?
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #1)
> Does this reproduce on 1.1?

Actually disregard - there's different set of priorities driven here, so I'll let Delphine triage these bugs to figure out what to do with them.
Keywords: qawanted
This issue reproduce on Leo v 1.1.0 COM RIL 

Environmental Variables
Device: Leo v 1.1.0 COM RIL
Build ID: 20131024041202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/e4cb5a852e3d
Gaia: 39b0203fa9809052c8c4d4332fef03bbaf0426fc
Platform Version: 18.1
RIL Version: 01.01.00.019.264 

The § symbol is missing on the Portuguese keyboard.


Please note that the symbol § appears on the English keyboard on Leo v 1.1.0 and Buri v 1.2.0
Asking Reuben for clarification about is this is expected behaviour or not
Flags: needinfo?(reuben.bmo)
(Assignee)

Comment 5

5 years ago
The en-US keyboard doesn't have that either… Do you mean $?
Flags: needinfo?(reuben.bmo) → needinfo?(ktucker)
(Assignee)

Comment 6

5 years ago
In any case, this is not expected in the sense that the pt-BR keyboard layout has never been touched by a l10n peer, but that symbol is never used in pt-BR anyway so IMO this bug is INVALID.
Created attachment 829645 [details]
EnglishKeyboard.png
Flags: needinfo?(ktucker)
In reply to Comment 5 the English keyboard does have the symbol in alt. A screenshot has been attached.

Slovak and Czech are shown to have the § symbol on the main keyboard layout according to http://www.branah.com/
Not sure that branah.com can be used as a reference for this kind of symbol.
If all locales in 1.1 and 1.2 (except English) don't have this symbol, it's probably an expected behaviour.
(Assignee)

Comment 10

5 years ago
Hm, yes, it looks like apps/keyboard/js/layout.js and keyboard/layouts/en.js are out of sync. The Brazilian ABNT2 layout has the § symbol (but only in the Alt Graphics table), so I guess I'll include it.

https://en.wikipedia.org/wiki/AltGr_key#Brazilian_ABNT2_keymap
Assignee: nobody → reuben.bmo
Great, thanks for the feedback reuben! Does this mean we should be including it for all locales? What are the next steps for this here please?
(Assignee)

Comment 12

5 years ago
It means every locale should decide if they want to include it, probably by looking at the keyboard layouts that are used by users of those locales.
(Assignee)

Comment 13

5 years ago
Created attachment 830534 [details]
Inherit default symbols layout in the pt-BR keyboard.

So after looking at this more closely I'm going to make the pt-BR layout inherit the symbols section of the default layout, I don't see why it should be different.
Attachment #830534 - Flags: review?(dflanagan)
(Assignee)

Comment 14

5 years ago
Comment on attachment 830534 [details]
Inherit default symbols layout in the pt-BR keyboard.

Ugh, isn't this supposed to redirect?
Attachment #830534 - Attachment is patch: false
Comment on attachment 830534 [details]
Inherit default symbols layout in the pt-BR keyboard.

I'm glad that localizers are looking over these layouts. I don't know where the defaults we have came from.
Attachment #830534 - Flags: review?(dflanagan) → review+
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 17

5 years ago
Verified present on the Hungarian keyboard.

Environmental Variables:
Device: (example: Buri v1.2 Mozilla RIL)
BuildID: 20131202004001
Gaia: 075e60c878b0eca68fba9e00bc85cb6eac03578a
Gecko: 14868788d50e
Version: 26.0
Firmware Version: V1.2_20131115

Comment 18

5 years ago
Previous comment was in error. Actual Environmental Variables:

Environmental Variables:
Device: Buri v1.2 COM RIL
BuildID: 20131202004001
Gaia: 075e60c878b0eca68fba9e00bc85cb6eac03578a
Gecko: 14868788d50e
Version: 26.0
Firmware Version: V1.2_20131115
Verified present is Macedonia

Environmental Variables
Device: Buri v1.2 COM RIL
Build ID: 20131202004001
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/14868788d50e
Gaia: 075e60c878b0eca68fba9e00bc85cb6eac03578a/A
Platform Version: 26.0
RIL Version: 01.02.00.019.102 
Firmware Version: v1.2_20131115

Comment 20

5 years ago
Confirmed that this symbol appears in Bulgarian, Macedonian, Slovak, Croation, Dutch, Greek, and Portugese(Brazil)
From our given list of languages to test, Portugese is the only keyboard missing this symbol.

Environmental Variables:
Device: Buri v1.2 COM RIL
BuildID: 20131202004001
Gaia: 075e60c878b0eca68fba9e00bc85cb6eac03578a
Gecko: 14868788d50e
Version: 26.0
Firmware Version: V1.2_20131115
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 21

5 years ago
(In reply to Lionel Mauritson from comment #20)
> Device: Buri v1.2 COM RIL
> BuildID: 20131202004001
> Gaia: 075e60c878b0eca68fba9e00bc85cb6eac03578a
> Gecko: 14868788d50e
> Version: 26.0

This never landed on 1.2; it should be fixed on 1.3. Can you please verify if that's the case?
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Comment 22

5 years ago
(In reply to Reuben Morais [:reuben] from comment #21)
> (In reply to Lionel Mauritson from comment #20)
> > Device: Buri v1.2 COM RIL
> > BuildID: 20131202004001
> > Gaia: 075e60c878b0eca68fba9e00bc85cb6eac03578a
> > Gecko: 14868788d50e
> > Version: 26.0
> 
> This never landed on 1.2; it should be fixed on 1.3. Can you please verify
> if that's the case?

It is indeed fixed on 1.3

1.3 Master Environmental Variables
Device: Buri v1.3 COM RIL
Build ID: 20131203040236
Gecko: 8648aa476eef
Gaia: 31808a29cfcffa584b6a88b4f1e515387f485a1b
Platform Version: 28.0a1
RIL Version: 01.02.00.019.102 
Firmware Version: v1.2_20131115
Hi Reuben,

It seems making pt-BR reuse the default symbol layout would lead to bug 976791, do you have a better idea on how to resolve this?
If not, I would suggest we backout this change first and spend some time on how to add '§' back.
Thanks.
Flags: needinfo?(reuben.bmo)
(Assignee)

Comment 24

5 years ago
Working on bug 976791.
Flags: needinfo?(reuben.bmo)
You need to log in before you can comment on or make changes to this bug.