Closed Bug 936581 Opened 6 years ago Closed 6 years ago

[B2G] Keyboard language display change not visibly apparent to user

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(feature-b2g:2.0, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S2 (23may)
feature-b2g 2.0
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: mclemmons, Assigned: rudyl)

References

Details

(Whiteboard: LocRun1.2 [ucid:SystemPlatform45, 1.5, ft:system-platform], [p=1])

Attachments

(2 files)

Description:
When user selects Romanian language as an additional keyboard on device, user attempt to change language in SMS app does not occur. Instead, nothing happens.

Reproduction Steps:
1) Updated Buri to BuildID: 20131108004004
2) Go to Settings App
3) Select Keyboards
4) Select Selected Keyboards
5) Select Add more keyboards
6) Select Romana
7) Select '<' button
8) Tap Homescreen button
9) Tap SMS App
10) Select Pencil icon
11) Tap globe icon on keyboard on device

Actual:
Nothing happens

Expected:
Keyboard changes. Long press of a character displays alternative options in the selected language

Environmental Variables:
Device: Buri v1.2 Com RIL
BuildID: 20131108004004
Gaia: b401bfed469e1d6db24e910f78732bad32843e8a
Gecko: a886c641a306
Version: 26.0


Notes:
Repro frequency: 100% (5/5)
See attached: logcat
Asking for koi since Romanian is a 1.2 shipping locale
blocking-b2g: --- → koi?
There are 2 updates to this reported issue:

1. In SMS, Contacts, or Browser App, when user is typing in a text field and taps the globe icon on device keyboard, there isn't a noticeable visual representation that the keyboard has changed to the different language. For example, if one changed from English to Romanian keyboard, there isn't a demonstrated bright flash on the screen or a shift of the keyboard that differs from the original selection - the latter occurs in build 1.1 as the middle keyboard characters slightly becomes narrower visually when first selecting the globe and wider when selecting the globe a second time

2. In SMS, Contacts, or Browser App, when user is typing in a text field and long presses the globe icon, the appropriate keyboard isn't changed consistently. If user selects Romanian so that it appears with a blue checkmark, intermittently the Romanian selection remains intact as expected while other times the English selection is re-selected by the device. The intermittent nature is about 50 percent (15 out of 30) on 2 different Buri devices on today's 11/8 Buri 1.2 Build

Environmental Variables:
Device: Buri v1.2 Com RIL
BuildID: 20131108004004
Gaia: b401bfed469e1d6db24e910f78732bad32843e8a
Gecko: a886c641a306
Version: 26.0
Summary: [B2G][1.2][l10n][Keyboard]Romanian: Keyboard does not display in selected Romanian language → [B2G][1.2][l10n][Keyboard]Romanian: Keyboard language display change not visibly apparent or consistent for user
Flagging David for help about this
Flags: needinfo?(dflanagan)
https://bugzilla.mozilla.org/show_bug.cgi?id=937170 has been created to separate the two issues in Comment 2. 

https://bugzilla.mozilla.org/show_bug.cgi?id=937170 deals with 2. In SMS, Contacts, or Browser App, when user is typing in a text field and long presses the globe icon, the appropriate keyboard isn't changed consistently
So if I'm understanding this correctly, this bug is about a visual or ux issue.  When the globe icon is tapped, the keyboard does switch from english to romananian, but because the layouts happen to look the same, the user doesn't realize that anything has changed.

I agree that we should fix that, but I doubt it is something we would block on.

I think Jan is the one who has most recently been involved with the keyboard switching animations, so I'm asking him for more info on this bug.

The other bug (keyboard does not reliably switch) seems much more serious. I'll comment there.
Flags: needinfo?(dflanagan) → needinfo?(janjongboom)
(In reply to David Flanagan [:djf] from comment #5)
> So if I'm understanding this correctly, this bug is about a visual or ux
> issue.  When the globe icon is tapped, the keyboard does switch from english
> to romananian, but because the layouts happen to look the same, the user
> doesn't realize that anything has changed.
> 
> I agree that we should fix that, but I doubt it is something we would block
> on.

Agree. While this results confusion but it make no sense to block at this point of time. We need a UX spec for v1.3 though.

> I think Jan is the one who has most recently been involved with the keyboard
> switching animations, so I'm asking him for more info on this bug.

Animation won't help here IMHO.
blocking-b2g: koi? → 1.3?
Flags: needinfo?(firefoxos-ux-bugzilla)
Android solves the problem by putting the name of the current active language on the space bar, which is quite a nice way I'd say. Dutch/English has the same problem as well.
Flags: needinfo?(janjongboom)
Flagging Carrie as I thought I may have seen a design that addressed this (though that may have been something else).
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(cawang)
Summary: [B2G][1.2][l10n][Keyboard]Romanian: Keyboard language display change not visibly apparent or consistent for user → [B2G] Keyboard language display change not visibly apparent to user
Keywords: l12y
(In reply to Stephany Wilkes from comment #8)
> Flagging Carrie as I thought I may have seen a design that addressed this
> (though that may have been something else).

We've came out an approach for the issue, but it won't be implemented for 1.3 due to timeframe. We'll target this for 1.4. Thanks!
Flags: needinfo?(cawang)
(In reply to cawang from comment #9)
> We've came out an approach for the issue, but it won't be implemented for
> 1.3 due to timeframe. We'll target this for 1.4. Thanks!

Triage: this issue is now considered as a part of one 1.4 committed feature. Ivan to link/track this bug to meta bug/user story bug.
blocking-b2g: 1.3? → 1.4+
Flags: needinfo?(itsay)
(In reply to Stephany Wilkes from comment #8)
> Flagging Carrie as I thought I may have seen a design that addressed this
> (though that may have been something else).

Hi Carrie,
Could you help to attach the UX design work in this bug for the implementation follow up.

Also set this bug to block system platform v1.4 feature meta bug
Flags: needinfo?(itsay) → needinfo?(cawang)
Whiteboard: LocRun1.2 → LocRun1.2 [ft:system-platform]
Whiteboard: LocRun1.2 [ft:system-platform] → LocRun1.2 [ucid:SystemPlatform45, 1.4:p2, ft:system-platform]
Whiteboard: LocRun1.2 [ucid:SystemPlatform45, 1.4:p2, ft:system-platform] → LocRun1.2 [ucid:SystemPlatform45, 1.4:p1, ft:system-platform]
Currently working on it! We'll deliver the spec soon (Sprint 2). Thanks!
Flags: needinfo?(cawang)
Feature work is not the blocker for the release. Reset blocking-b2g flag. This is just to change the way we tag feature work bugs. We still follow up our sprint planning for the FC
blocking-b2g: 1.4+ → ---
Move this one to v1.5 since refactoring work in bug 956169 is moved to v1.5. It makes more sense to do this work on top of new keyboard.
Whiteboard: LocRun1.2 [ucid:SystemPlatform45, 1.4:p1, ft:system-platform] → LocRun1.2 [ucid:SystemPlatform45, 1.5, ft:system-platform]
No longer blocks: 1.4-system-platform
I do not agree with moving this to 1.5. This is a trivial change that would have a big UX improvement for people that use FFOS in multiple languages. We can do this without bug 956169.
 
Casey, do you know if this made it into one of the keyboard spec docs, and if so, where is it?
Flags: needinfo?(kyee)
Jan, It doesn't appear to be in the latest spec.  Flagging Carrie to see if we can get an update.

I do agree that it may not be obvious switching between different roman-character keyboards that you have actually switched keyboards.   I would recommend that we add some kind of UI that displays the keyboard change.
Flags: needinfo?(kyee) → needinfo?(cawang)
Hi everyone, 

The Spec is done, but we've been told this will be in 1.5. ni? Ivan to confirm this. Thanks!
Flags: needinfo?(cawang) → needinfo?(itsay)
Well, if the spec is not crazy hard to implement I'm happy to take it for a 1.4 sprint.
Yes, this is moved to v1.5 due to the de-scope of v1.4 feature set. No new feature shall be landed from now.
Flags: needinfo?(itsay)
This is in the latest spec, adding it to bug 985328
Blocks: 985328
Tracked with bug 985328, so remove the upper level dependency.
No longer blocks: 2.0-system-platform
Should not be a language-specific issue, so remove the dependency.
No longer blocks: 931569
Assignee: nobody → rlu
Whiteboard: LocRun1.2 [ucid:SystemPlatform45, 1.5, ft:system-platform] → LocRun1.2 [ucid:SystemPlatform45, 1.5, ft:system-platform], [p=1]
Target Milestone: --- → 2.0 S2 (23may)
Please refer to the spec in bug 983043.
This patch is to show shortLabel, say 'En' for English on the IME switching key, to replace the original 'Globe' icon.

For the keyboard languages that I could not think of a good shortLabel for, I adopted a strategy that reuse the same shortLabel for them.
e.g. for 'English - Dvorak' keyboard layout, the shortLabel is still 'En'.

Omega,

Could you help do the UI review first?
Thanks.

Tim,

Please help review this change.
Thank you.
Attachment #8425403 - Flags: ui-review?(ofeng)
Attachment #8425403 - Flags: review?(timdream)
Status: NEW → ASSIGNED
Comment on attachment 8425403 [details] [review]
Patch V1 - pull request 19428

Code looks good.
Attachment #8425403 - Flags: review?(timdream) → review+
Comment on attachment 8425403 [details] [review]
Patch V1 - pull request 19428

When there are multi-keyboards (with IME switch key), there shouldn't be a period (,) key at bottom row in Symbol layouts.
Not sure if it's in the scope of this bug.
Attachment #8425403 - Flags: ui-review?(ofeng) → ui-review-
Yeah, that would need us to re-define the symbol panel so that it could have 2 faces,
 1. With ',' on the first 3 rows (because we don't have it when the IME switching key is present).
 2. Without ',', so we need an alternative char to replace it.

Would suggest to handle this with a separate bug.
Flags: needinfo?(ofeng)
Comment on attachment 8425403 [details] [review]
Patch V1 - pull request 19428

(In reply to Rudy Lu [:rudyl] from comment #26)
> Yeah, that would need us to re-define the symbol panel so that it could have
> 2 faces,
>  1. With ',' on the first 3 rows (because we don't have it when the IME
> switching key is present).
>  2. Without ',', so we need an alternative char to replace it.
> 
> Would suggest to handle this with a separate bug.

If so, ui-review+ this patch.
Attachment #8425403 - Flags: ui-review- → ui-review+
Flags: needinfo?(ofeng)
Comment on attachment 8425403 [details] [review]
Patch V1 - pull request 19428

Before landing, I'd like to get some feedback from our l10n team.

Hi Pike,

Could you please help take a look at this patch since this change is related to l10n?
A short summary would be we added a shortLabel, like 'En' for English layout.
Thanks.
Attachment #8425403 - Flags: feedback?(l10n)
Comment on attachment 8425403 [details] [review]
Patch V1 - pull request 19428

I share the concern about the short names. There's some ambiguity involved, not sure if those are resolved by the visual appearance of the keyboards that have the same shortnames?

Also, for non-latin keyboards, the shortnames might want to be in the local script. I see you did that for Chinese, but not for others. That might be worth reaching out to the original contributors for those keyboards.

Note, we had some feedback on the UX spec for the keyboard, I added that in bug 983043 comment 12.
Attachment #8425403 - Flags: feedback?(l10n)
Hi Pike,

(In reply to Axel Hecht [:Pike] from comment #29)
> Comment on attachment 8425403 [details] [review]
> Patch V1 - pull request 19428
> 
> I share the concern about the short names. There's some ambiguity involved,
> not sure if those are resolved by the visual appearance of the keyboards
> that have the same shortnames?

Thanks for your feedback.
I agree with you on this, which I also raised during spec review meeting.

Originally, I wanted to add "En" for English and leave out the layouts with longer name, like "English Dvorak", and keep showing "Globe" key for those layouts that we couldn't think of a better shortLabel for.
However, in the end, I think if we also provide "En" for En-Dvorak, it provides more info than "Globe" key. That is why I took this approach for now.

> 
> Also, for non-latin keyboards, the shortnames might want to be in the local
> script. I see you did that for Chinese, but not for others. That might be
> worth reaching out to the original contributors for those keyboards.

Yeah, agree, but I don't think I could gather all the shortLabels in one patch, so would prefer to land this patch first and we could refine the shortLabel one by one once we have contributors' help on this. 

> 
> Note, we had some feedback on the UX spec for the keyboard, I added that in
> bug 983043 comment 12.

Do you agree we could land this first?
Thank you.
Flags: needinfo?(l10n)
Comment on attachment 8425403 [details] [review]
Patch V1 - pull request 19428

Let's land this to gather some feedback and modify the shortLabel if needed.

Gaia master,
https://github.com/mozilla-b2g/gaia/commit/8d24ed756f3b50671649bed9acd119017451aeeb
Flags: needinfo?(l10n)
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
I think the short label solution is pretty OK, as when switching between En-Dvorak and normal En you'll see the keyboard layout visually changed already. So enough info there. I think its mostly the autocorrect language that should be communicated.
feature-b2g: --- → 2.0
You need to log in before you can comment on or make changes to this bug.