Implement question statuses

RESOLVED FIXED in 2013Q4

Status

support.mozilla.org
Knowledge Base Software
P2
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: atopal, Assigned: rrosario)

Tracking

(Blocks: 1 bug)

unspecified
2013Q4

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=contributor c=questions p=3 s=2013.23)

(Reporter)

Description

4 years ago
In order to highlight what is really important for forum contributors to see  and to get better at identifying our weak spots, we need better awareness of the status of questions in the support forum.

To that end we have decided on 3 states with 2 sub states each:

For a graphical representation see: https://docs.google.com/a/mozilla.com/drawings/d/1tN7asQ7pIB0SxIWPYCGpokL2gD6a5Dj5QIgJay0AFn4/edit

* Needs Attention
** New 
** Answer didn't work (for those that are waiting for our reply)

* Responded
** Needs info (for those where we need more info)
** Solution provided (for those where we need to know if the solution worked)

* Done
** Solved
** Locked (for those that should not get further replies)


How to decide what the status of a thread is:

If question is marked as "locked" or "solved"
    the status is "Done"
else if contributor is last to post
    the status is "Responded"
else if OP is last to post
     the status is "Needs Attention"


How sub statuses are awarded:

New: When question is created
Solved: manually set by OP or a moderator
Locked: manually set by moderator

"Answer didn't work", "Solution provided", and "Needs info" are awarded after a posting:

if (question is not marked as done) AND (poster is not OP)
  if "needs info" checked
    sub status is "needs info" 
  else
    sub status is "solution provided"
else if (question is not marked as done) AND (poster is OP)
  sub status is "answer didn't help 

"needs info" is a flag set when editing an answer.

It is assumed that a thread can only be in one status/sub status at a time. Awarding one sub status removes all others.


I'm using pseudo-code only to give a crisp definition of how sub statuses are awarded, not suggesting anything about implementation details. 


Things to keep in mind when implementing this:

* We need to be able to create views based on states.
eg. A question listing consisting only of questions in the "Needs Attention" status.

* For each status and sub status we need to be able to create line graphs that represent their share per day.
eg.
For questions created on November 1st 2013:
* 20% are in the "Attention needed" status
** 3% are in the "New" sub status
** 17% are in the "Answer didn't help" sub status.

* 30% are in the "Responded" status
** 5% are in the "needs info" sub status"
** 25% are in the "Solution provided" sub status

* 50% are in the "locked" status
** 45% are in the "solved" sub status
** 5% are in the "locked" sub status


Feel free to mark this bug as a tracker and file individual bugs to implement parts of this, if that makes more sense.
(Reporter)

Updated

4 years ago
Duplicate of this bug: 928610
(Assignee)

Comment 2

4 years ago
3pts for:

* Model manager to get questions in each of the states
* Infrastructure for "needs info"
* Figure out if we need a status column
Whiteboard: u=contributor c=questions p= s=2013.23 → u=contributor c=questions p=3 s=2013.23
(Assignee)

Comment 3

4 years ago
*gulp*
Assignee: nobody → rrosario
(Assignee)

Comment 4

4 years ago
In a pull request:
https://github.com/mozilla/kitsune/pull/1734
According to current & long standing forum guidelines only one use should ask a single question in a particular thread. In practice many threads have multiple user asking questions and contributors often answer such secondary questions.

Are we going to 
1.) - Take steps to enforce single user questions (by guidelines  or even by software permissions)
  This would be best in my opinion
2.) - Allow the present practices to continue.
(Sorry hit return too early.) Continuing from above.

If option 2 continue as at present with secondary questions in a thread.
Presumably any secondary question does not change the thread status. We will for instance have solved questions threads where info is needed to answer the secondary question. It will get messy as it is currently. Presumably this will be accepted and the users may be blamed for not following guidelines.

Option 1 trying to enforce single user per thread.
That is probably only practical by promoting adherence with guidelines.
Presumably the forum could be engineered so that only a single user (none contributor) could post, however the main problem I foresee with any attempt to always restrict threads to a single user is that sometimes other users will have the answer of vital information. Think about breaking issues. The me-too comments may be really useful in trying to find the solution and get an idea of the impact of an issue.
(Reporter)

Comment 7

4 years ago
We have been and we'll strive to follow a Question/Answer model for support threads. Every new question should be asked in a new thread.

This is not an easy problem to solve, on one hand we want people to jump right into a thread and provide more information or even answers, on the other other we don't want them to use that opportunity to ask new questions. Solutions to this problem might involve deciding which use case has priority for us and optimizing for that, different user interfaces for users and contributors, etc. In any case, it's beyond the scope of this bug.
(Assignee)

Comment 8

4 years ago
Landed on master:
7f4a1c63688911e3bdbd7f3f08d8fcfbb7b50cb7
(Assignee)

Comment 9

4 years ago
Full commit url:
https://github.com/mozilla/kitsune/commit/7f4a1c63688911e3bdbd7f3f08d8fcfbb7b50cb7
(Assignee)

Comment 10

4 years ago
This was just infra that isn't used on prod yet, closing out.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.