Defect - Fuzzy font when scrolling in Metro chrome

RESOLVED DUPLICATE of bug 946475

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 946475
5 years ago
5 years ago

People

(Reporter: Kapranov, Assigned: mattwoodrow)

Tracking

({regression})

28 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox27 unaffected, firefox28 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 829744 [details]
Снимок экрана (165).png

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131025151332

Steps to reproduce:

Fuzzy font when scrolling in flyoutpanel
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Fuzzy font when scrolling → Fuzzy font when scrolling in Metro chrome
Whiteboard: [triage]

Updated

5 years ago
Blocks: 838081
Summary: Fuzzy font when scrolling in Metro chrome → Defect - Fuzzy font when scrolling in Metro chrome
Whiteboard: [triage] → [triage] feature=defect c=tbd u=tbd p=0

Comment 1

5 years ago
I've been seeing this on scrollable form drop downs as well. Also probably the same as the overlay button rendering bug 936609.

Updated

5 years ago
Component: General → Graphics
Product: Firefox for Metro → Core

Updated

5 years ago
Whiteboard: [triage] feature=defect c=tbd u=tbd p=0 → [block28] feature=defect c=tbd u=tbd p=0

Comment 2

5 years ago
Bug 936500 is also likely the same bug.

Comment 4

5 years ago
Some potential suspects below. I don't see much in the way of gfx landings though. Kats had a couple apzc landings but this rendering bug shows up in scrollable chrome vs. apzc content. Matt any chance your landings might have caused this bug or bug 936609? 

Matt Woodrow — Bug 923434 - Use DrawSurface in ThebesLayerBuffer instead of FillRect.
Matt Woodrow — Bug 926023 - Use the value of SetPermitSubpixelAA for DrawTargetCairo.
Flags: needinfo?(matt.woodrow)

Comment 5

5 years ago
I backed out "Don't use operator source for D2D" locally and confirmed it was the cause of this particular bug.
Blocks: 923434
tracking-firefox28: --- → ?

Updated

5 years ago
Blocks: 936609
(Assignee)

Comment 6

5 years ago
Bas, any idea why this might happen? I can't see anything wrong with the changes, it seems like it should be identical.
Flags: needinfo?(matt.woodrow) → needinfo?(bas)
(In reply to Matt Woodrow (:mattwoodrow) from comment #6)
> Bas, any idea why this might happen? I can't see anything wrong with the
> changes, it seems like it should be identical.

These fonts aren't fuzzy.. they're non-antialiased. The opposite of fuzzy, I'm going to think about this a little more.
Flags: needinfo?(bas)

Updated

5 years ago
status-firefox27: --- → unaffected
status-firefox28: --- → affected
tracking-firefox28: ? → +

Updated

5 years ago
Blocks: 941026

Updated

5 years ago
No longer blocks: 941026
Duplicate of this bug: 941026

Updated

5 years ago
Whiteboard: [block28] feature=defect c=tbd u=tbd p=0 → [block28] [GFX] feature=defect c=tbd u=tbd p=0

Comment 9

5 years ago
(In reply to Bas Schouten (:bas.schouten) from comment #7)
> (In reply to Matt Woodrow (:mattwoodrow) from comment #6)
> > Bas, any idea why this might happen? I can't see anything wrong with the
> > changes, it seems like it should be identical.
> 
> These fonts aren't fuzzy.. they're non-antialiased. The opposite of fuzzy,
> I'm going to think about this a little more.

Bas this blocks our merge for fx28. Can we maybe back out the offending patch from bug 923434? Or if def it maybe? Alternatively if you think we can come up with a fix that can land on aurora, we can bump this out to relerase28.
Flags: needinfo?(bas)

Updated

5 years ago
Keywords: regression
Whiteboard: [block28] [GFX] feature=defect c=tbd u=tbd p=0 → [beta28][gfx] feature=defect c=tbd u=tbd p=0

Updated

5 years ago
Blocks: 844132
(Assignee)

Updated

5 years ago
Assignee: nobody → matt.woodrow
Matt, the original bug got uplifted to aurora, which means that it will be beta in a couple of days.  Is this regression less of an issue, or do we think we should need to uplift this fix to match?
Flags: needinfo?(matt.woodrow)
(Assignee)

Comment 11

5 years ago
I think we should uplift for this, it's  a fairly bad regression in some cases.

The fix is fairly simple too.
Flags: needinfo?(matt.woodrow)

Updated

5 years ago
Whiteboard: [beta28][gfx] feature=defect c=tbd u=tbd p=0 → [beta28][gfx]
(Assignee)

Comment 12

5 years ago
Is this fixed on m-c? I suspect it will have been fixed by bug 946475.
Flags: needinfo?(bas)

Comment 13

5 years ago
(In reply to Matt Woodrow (:mattwoodrow) from comment #12)
> Is this fixed on m-c? I suspect it will have been fixed by bug 946475.

yes it does.
No longer blocks: 838081, 844132, 936609, 923434
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Whiteboard: [beta28][gfx]
Duplicate of bug: 946475
tracking-firefox28: + → ---
You need to log in before you can comment on or make changes to this bug.