SUMO is slow - maybe slower for logged in users

RESOLVED FIXED in 2013Q4

Status

support.mozilla.org
General
P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: verdi, Unassigned)

Tracking

unspecified
2013Q4

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=performance p=5 s=2013.24 [sumo-is-cranky][fix-me-please])

(Reporter)

Description

4 years ago
SUMO was taking a long time to load yesterday (11/8) and Ricky did something that seemed to help. But today it's slow again. I'm trying to edit and approve articles and I'm often waiting 20 seconds for an article to load, to submit a revision or approve a revision. I tried browsing on other computers (connected to the same router) and I had the same experience. I also tried to browse while logged out and it seemed to be somewhat better but, of course, I can't test editing or reviewing.

Comment 1

4 years ago
Appears network related. Tracert says that "above net" are running slowly.

Ericz said earlier that he's enquired about the issues

Comment 2

4 years ago
related discussion at https://support.mozilla.org/en-US/forums/contributors/709619?last=55193&page=2#post-55189
Four support webservers - support[1345].webapp.phx1.mozilla.com - have hit max clients and stopped responding to web requests today. Something is very unhappy on the back end.

Does not appear network related.
Depends on: 934601
Priority: -- → P1
Whiteboard: u=user c=performance p=5 s=2013.24 [sumo-is-cranky][fix-me-please]
Target Milestone: --- → 2013Q4
One thing about this bug is that it's about "slowness". That's one of those symptoms that comes from a variety of causes and has different manifestations, too. I mention that because I'm going to tweak the scope of this bug to cover the excessive slowness problems that are happening once-a-day or thereabouts because one or more of the servers stop handling new connections. That's what comment #3 is about.

I spent some time pouring over Graphite data and bug comments and then asked phrawzty to back out a configuration change that happened on November 7th that I contend turned an occasional slowness problem into a very frequent slowness problem. From the metrics I'm looking at, the site appears to be operating normally since.

This doesn't fix the problem that the change on November 7th was intended to fix, though. That problem continues and we/someone will look into tackling that in other ways.

I'll keep an eye on things and see if the problem in comment #3 recurs.
I haven't seen any recurrence of comment #3 in the last three days.

Verdi: Are you still experiencing the extreme site-wide slowness problems? If not, I propose we close this bug.
Flags: needinfo?(mverdi)
(Reporter)

Comment 6

4 years ago
(In reply to Will Kahn-Greene [:willkg] from comment #5)
> I haven't seen any recurrence of comment #3 in the last three days.
> 
> Verdi: Are you still experiencing the extreme site-wide slowness problems?

Everything seems to be running normally now.
Flags: needinfo?(mverdi)
Yay!

Marking as fixed!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Seems fine to me as well - fast as a lightning bolt!
unblocking
No longer depends on: 934601
You need to log in before you can comment on or make changes to this bug.