0.9.3 Installer crashes Mac OS 9.1 iBook

VERIFIED WORKSFORME

Status

SeaMonkey
Installer
--
critical
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Brad Schrick, Assigned: Syd Logan)

Tracking

({crash, stackwanted})

Trunk
PowerPC
Mac System 9.x
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.78 (Macintosh; U; PPC)
BuildID:    20010804

Like the 0.9.2 installers, the 0.9.3 installer crashed.

I chose a different folder.  When I tried again, and accepted the defaults, 
Mozilla 0.9.3 installed.

BUT -- It hung 9.1 on startup (no browser window, after splash is gone), had to 
do hard restart.

This also wrecked my 0.9.2 folder, and now 0.9.2 hangs on startup as well. (had 
to do hard restart)

Not happy.  Had similar problems on Cube when I had one, with 0.9.2

Mac OS 9.1 -- iBook -- 192MB RAM

Reproducible: Always
Steps to Reproduce:
1.Try to install, choose different folder for installation
2.Install with default choices
3.Try to start up after installation

Actual Results:  iBook hangs, requires hard restart

Comment 1

17 years ago
Works for me on a Desktop G4. Reporter, try disabling any extra extensions you have 
installed. Also be sure to follow the installer's advice and quit any running apps.

Comment 2

17 years ago
!win32
Assignee: ssu → syd
QA Contact: gemal → gbush

Comment 3

17 years ago
Reporter, any luck with my suggestions? I'm not seeing any other reports of this 
problem.

Comment 4

17 years ago
Need a stacktrace or a talkback id for this to be useful at all.
Severity: major → critical
Keywords: crash, stackwanted

Comment 5

17 years ago
Since he's talking about the installer, it will have to be a trace.

Comment 6

17 years ago
From Reporter:
The point is that this crash does not trigger TalkBack

Mozilla and Netscape 6.1 now both crash my iBook at startup

I am no longer willing to try either of them -- it has taken way too long to
repair my disk for each crash

If macsbug would help, perhaps I could try that again... but it is not inviting!
  The iBook is my life...

-- B.rad

Comment 7

17 years ago
Reporter, you must be willing to participate in order to resolve this bug. This is not a 
report-and-forget technical support hotline.

That said, perhaps you have other problems with your iBook. Does Mozilla crash when 
you start up using only the Mac OS 9.1 All extension set? Do you run Disk First Aid or 
some other diagnostic/repair tool reguarly?

Comment 8

17 years ago
Reporter, please address my questions. Also, please retest using 0.9.4.
(Reporter)

Comment 9

17 years ago
Moz 0.9.4 installed and runs without problems on my iBook.  Good news.

Current suspect here is the Internet control panel.

For a clue, however, Opera 5b3 froze the system in the same apparent way as reported for Moz 0.9.3 after installation (which did not crash the system), after startup.  Opera was selected in the Internet control panel as the default browser.  

Opera started, but did not open a browser window.  Same behavior as Moz 0.9.3

Selecting Netscape (already installed) as the default browser allowed Opera to start and run without problems.

Comment 10

17 years ago
Brad, have you tested starting up using only the "Mac OS 9 All" extension set in order to 
rule out third-party extensions?

Comment 11

17 years ago
reporter's comment sounds like a worksforme. reopen if you disagree
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 12

17 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.