Gaia keyboard doesn't trigger async animation

RESOLVED FIXED in Firefox 26, Firefox OS v1.2

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: BenWa, Assigned: BenWa)

Tracking

unspecified
mozilla28
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:koi+, firefox26- fixed, firefox27- fixed, firefox28- fixed, b2g-v1.2 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
STR:
1) Click on 'I'm thinking off...' field on the b2g homescreen
2) Hide the keyboard

Notice the animation is very janky. This animation looks to be properly designed to hit async animations and the keyboard is layerized during the animation as well.

CSS property:
http://mxr.mozilla.org/gaia/source/apps/system/style/system/keyboard.css#25
(Assignee)

Comment 1

5 years ago
Any ideas dzbarsky why async animations aren't hit here?
Flags: needinfo?(dzbarsky)
I don't have a working B2G build at the moment.  Does enabling animation logging show anything interesting in logcat?
Flags: needinfo?(dzbarsky)
(Assignee)

Updated

5 years ago
Blocks: 932764
(Assignee)

Comment 3

5 years ago
No, nsLayoutUtils::IsAnimationLoggingEnabled isn't even checked.
Flags: needinfo?(dzbarsky)

Updated

5 years ago
See Also: → bug 936535
(Assignee)

Comment 4

5 years ago
Thanks dzbarsky. I found the problem.

Looks like it was a regression from bug 929362 after all.
Depends on: 929362
Flags: needinfo?(dzbarsky)
(Assignee)

Comment 5

5 years ago
Created attachment 831772 [details] [diff] [review]
patch - logic error
Assignee: nobody → bgirard
Status: NEW → ASSIGNED
Attachment #831772 - Flags: review?(roc)
Ugh.
(Assignee)

Comment 7

5 years ago
Comment on attachment 831772 [details] [diff] [review]
patch - logic error

Ohh you're still up :). Feel free to steal the review. This is quite trivial really.
Attachment #831772 - Flags: review?(mstange)
(Assignee)

Updated

5 years ago
blocking-b2g: --- → koi?
status-firefox26: --- → affected
status-firefox27: --- → affected
status-firefox28: --- → affected
tracking-firefox26: --- → ?
tracking-firefox27: --- → ?
tracking-firefox28: --- → ?
Attachment #831772 - Flags: review?(roc)
Attachment #831772 - Flags: review?(mstange)
Attachment #831772 - Flags: review+
(Assignee)

Updated

5 years ago
Blocks: 937630
blocking-b2g: koi? → koi+
https://hg.mozilla.org/mozilla-central/rev/00c3e5302d24
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
https://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/8151f46ae991

Is this B2G-only? If so, I assume we don't care about uplifting this to Aurora/Beta and the status for those release can be wontfix.
status-b2g-v1.2: --- → fixed
status-firefox28: affected → fixed
Flags: needinfo?(bgirard)
(Assignee)

Comment 11

5 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #10)
> https://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/8151f46ae991
> 
> Is this B2G-only? If so, I assume we don't care about uplifting this to
> Aurora/Beta and the status for those release can be wontfix.

IMO I would rather see this make it to aurora as well just to keep things simple. This is something users can turn on for testing.
Flags: needinfo?(bgirard)
I assume "this" is OMTA? In that case, please request approval. Also note that b2g26 != beta, so Firefox 26 is still affected.
(Assignee)

Comment 13

5 years ago
Comment on attachment 831772 [details] [diff] [review]
patch - logic error

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 929362
User impact if declined: none, unless users have preference flipped for testing.
Testing completed (on m-c, etc.): on m-c. Simple logic change fix up
Risk to taking this patch (and alternatives if risky): none, this is preffed off
String or IDL/UUID changes made by this patch:none

bug 929362 uplifted a regression and I'd like to uplift the fix everywhere the regression went in. This is used by OMTAnimation which is only enabled by default on b2g and I'd like to avoid dealing with a matrix of trees where this is or isn't fixed.
Attachment #831772 - Flags: approval-mozilla-beta?
Attachment #831772 - Flags: approval-mozilla-aurora?
This isn't user impacting enough for tracking and it's preffed off, but we'll take the low risk patches for uplift.
tracking-firefox26: ? → -
tracking-firefox27: ? → -
tracking-firefox28: ? → -
Attachment #831772 - Flags: approval-mozilla-beta?
Attachment #831772 - Flags: approval-mozilla-beta+
Attachment #831772 - Flags: approval-mozilla-aurora?
Attachment #831772 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.