Autocomplete doesn't work with words that have space

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
4 years ago

People

(Reporter: ndtrung4419, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131030203622

Steps to reproduce:

Try the new Vietnamese word-list at https://github.com/lewtds/gaia/commit/a9d4484cb3229f93a8c40047374643e79cae9cb1

Type in "linh" + SPACE + "tinh" (meaning 'miscellaneous').



Actual results:

Every time the user presses the space bar, the current composition is cleared.

Since most Vietnamese words are made up of smaller space-delimited syllables as if they were words, the engine can only auto-complete syllables.


Expected results:

The word "linh tinh" should be shown in the suggestion list.
(Reporter)

Updated

5 years ago
Blocks: 934198

Comment 1

4 years ago
Let's figure out if this is caused by dictionary file. Can you provide a test case with dictionary with few space-delimited syllables.
Flags: needinfo?(ndtrung4419)
This was a problem of using latin IME for Vietnamese. Vietnames uses its own IME now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.