Unable to display very long "From:" field properly

RESOLVED FIXED in Thunderbird 29.0

Status

Thunderbird
Message Reader UI
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Man-wai Chang, Assigned: sshagarwal)

Tracking

24 Branch
Thunderbird 29.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 2 obsolete attachments)

(Reporter)

Description

5 years ago
Created attachment 829835 [details]
thunderbird.long.from.bug.jpg

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131025151332

Steps to reproduce:

The following message source was not displayed properly! Notice the extremely long "From:" field.

[***begin****]
From: "WinWinWin" <=?Big5?Q?=BB=F9=BD=E2=A7=EB=B8=EA_winwinwinwinwinwinwinwinwinwinwi?= =?Big5?Q?nwinwinwinwwwwwwwwwwwwwiiiiiiiiiiiiii?= =?Big5?Q?iiinnnnnnnnnmmmmmmmmmmmmmmmmmmmmmmmmm?= =?Big5?Q?mmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmm__XD?=>
Newsgroups: 3business.finance
Subject: =?Big5?Q?=CB=DD=B6Q=AC=5B_=BC=C6=BA=BF=C0s=A5=CD=BD=DE=A4Q=BFE?=
Content-Type: text/plain; charset=Big5; format=flowed
X-Newsreader: Android Usenet Reader (DEMO) 1.20.2
X-Phone-Model: GT-I9100
X-Android-OS-Version: 4.1.2
NNTP-Posting-Host: 121.202.251.238
X-Original-NNTP-Posting-Host: 121.202.251.238
Message-ID: <527e14b7@news.3home.net>
Date: 9 Nov 2013 18:55:51 +0800
X-Trace: news.3home.net 1383994551 121.202.251.238 (9 Nov 2013 18:55:51 +0800)
Organization: 3home.net
Lines: 7
Path: news.3home.net
Xref: news.3home.net 3business.finance:2302474

¥|¦Ê¥î¤Q¤¸ ¦³¤T±i¥d

--
Android Usenet Reader
http://android.newsgroupstats.hk
--

[***end****]


Actual results:

See attached screenshot (thunderbird.long.from.bug.jpg)!


Expected results:

The UI should display the long "From:" properly, not stretching beyond screen width. Truncating the tail part of the long "From:" field could be a solution, or it could be displayed as "extremely long..... field".

Comment 1

5 years ago
Please try in Safe Mode. It looks like you're using an add-on to change the message header, which is probably causing the issue.
(Reporter)

Comment 2

5 years ago
I was using two add-ons, and I also used userChrome.css to increase the font size.

1. CompactHeaders 2.0.8
2. Header Tools Lite 0.4.4

I attached a new screenshot using Safe Mode, under the following name:
thunderbird-safe-mode.long.from.bug

I think the add-ons did NOT really affect the behavior of displaying the long "From:" field.
(Reporter)

Comment 3

5 years ago
Created attachment 830121 [details]
thunderbird-safe-mode.long.from.bug.jpg
confirming as seen in screenshot attachment 830121 [details]
tb 24.1.0 WinXP
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

5 years ago
Maybe this needs just some css "clip" rule to add an ellipsis (...) when needed.
(Assignee)

Comment 6

5 years ago
Created attachment 8355076 [details] [diff] [review]
Patch v1

Thanks to :Paenglab.
Attachment #8355076 - Flags: review?(richard.marti)
Comment on attachment 8355076 [details] [diff] [review]
Patch v1

Review of attachment 8355076 [details] [diff] [review]:
-----------------------------------------------------------------

r- because this didn't work. It should be max-width. And the patch is only for Linux. What about OS X and Windows?

I think also this approach with max-width isn't what we want here. What would be the correct width. The 40px was only a test value to check if it would work and way to small for normal use. The width should be dynamic because we have small screens but also wide screens and the fields should be as wide as possible. The From email field should not expand the expandedHeadersBox over the visible width. This can't be done only with CSS, this would also need XUL adjustments.

::: mail/themes/linux/mail/messageHeader.css
@@ +502,5 @@
>  }
>  
> +.emaillabel {
> +  min-width: 40px;
> +}

.emaillabel has now no more padding and margin of 0px! Also the overflow is missing.

The min-width was a typo. It should be max-width.
Attachment #8355076 - Flags: review?(richard.marti) → review-
(Assignee)

Comment 8

5 years ago
Created attachment 8355114 [details] [diff] [review]
Patch v2

I don't know why min-width worked for me.
I hope this change is acceptable. Also, I couldn't find what sort of changes are needed in XUL, please let me know.

Thanks.
Attachment #8355076 - Attachment is obsolete: true
Attachment #8355114 - Flags: review?(richard.marti)
(Assignee)

Updated

5 years ago
OS: Windows 8.1 → All
Hardware: x86_64 → All
Comment on attachment 8355114 [details] [diff] [review]
Patch v2

Review of attachment 8355114 [details] [diff] [review]:
-----------------------------------------------------------------

Great, I learned a new unit and have to revise my opinion it's not only doable with CSS. :)
I tried it also on a message with 18 recipients and it worked also there, the 'xx more' label was still fully visible.

Instead of copying the whole block with padding, margin and overflow, please add a new block with only

.emaillabel {
  max-width: 60vw;
}

And please add a comment why this max-width is set.

With this changed r+
Attachment #8355114 - Flags: review?(richard.marti) → review+
(Assignee)

Comment 10

5 years ago
Created attachment 8355161 [details] [diff] [review]
Patch for check-in

Thanks to :squib for this unit.
Carrying over review from Paenglab.
Do I need any other review flags or can I mark this patch for check-in?
Attachment #8355114 - Attachment is obsolete: true
Attachment #8355161 - Flags: review+
Comment on attachment 8355161 [details] [diff] [review]
Patch for check-in

I'm giving ui-r+ to be sure.
Attachment #8355161 - Flags: ui-review+
So what's the new layout for long from (screenshot)?
Created attachment 8355199 [details]
Long name with patch
(Assignee)

Comment 14

5 years ago
Okay, thanks :)
Assignee: nobody → syshagarwal
Status: NEW → ASSIGNED
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/f0958a2158b8
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 29.0
You need to log in before you can comment on or make changes to this bug.