Navigator only installation results in segfault

VERIFIED FIXED

Status

VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: jccann, Assigned: slogan)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Need ETA])

(Reporter)

Description

17 years ago
After running the 0.9.3 installer, select 'Navigator Only' and do not check box
to save downloaded files.  Files are downloaded and during installation, the
installer segfaults.  Installation is not completed.  I found this problem also
in Moz 0.9.2

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010801
Slackware 7.0
Does it work if you install ALL ?
(Reporter)

Comment 2

17 years ago
Yes, it works if I select 'install all'.

Comment 3

17 years ago
!win32
Assignee: ssu → syd
QA Contact: gemal → gbush

Comment 4

17 years ago
Reporter, do you use the net installer or the -sea version?

Comment 5

17 years ago
Oh sorry, obviously you're using the net installer. I will try to reproduce this
now.

Comment 6

17 years ago
I just did a navigator-only install with the net-installer of 0.9.3 and that
worked just fine. Reporter, can you try to download the net-installer of a
recent nightly build and see if it crashes for you too? If possible, please run
the installer through gdb to catch the crash. Nightly builds can be found at
http://ftp.mozilla.org/pub/mozilla/nightly/latest-trunk/.
(Reporter)

Comment 7

17 years ago
Hello.I downloaded the nightly build now (9/13), ran the net-installer with 'Navigator Only' checked (and 'do not save downloaded files') checked.All of the xpi files downloaded and then the following dialog box appears during the extraction of libpic4.so :  Fatal error [-618]: Could not open xpistub library.I did not observe this error before.  When I click on 'OK' button in error dialog, the installer program halts.  So, the 'segfault' is no longer a problem, but the 'Navigator only' install still does not work.

Comment 8

17 years ago
usiing nightly 2001091311- Navigator only install
I see the -621 error- cannot install psm
but install finishes and launches - no crash/segfault

John,  should psm be part of these builds?   
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

17 years ago
N6.2 - build 2001092604branch 
Navigator only install-   quits on what appears
to be last file of download- error message says 'could not find all files to
download- retrying and quits
custom.end (last file) does exist in xpi directory- as well as all 8 files it
says it is downloading
recommended and full and custom - all install setup types work



aGtk-CRITICAL **: file gtkprogress.c: line 518 (gtk_progress_set_percentage):
assertion `percentage >= 0 && percentage <= 1.0' failed.

Gtk-CRITICAL **: file gtkprogress.c: line 518 (gtk_progress_set_percentage):
assertion `percentage >= 0 && percentage <= 1.0' failed.

Gtk-CRITICAL **: file gtkprogress.c: line 518 (gtk_progress_set_percentage):
assertion `percentage >= 0 && percentage <= 1.0' failed.

Gtk-CRITICAL **: file gtkprogress.c: line 518 (gtk_progress_set_percentage):
assertion `percentage >= 0 && percentage <= 1.0' failed.

Gtk-CRITICAL **: file gtkprogress.c: line 518 (gtk_progress_set_percentage):
assertion `percentage >= 0 && percentage <= 1.0' failed.

Gtk-CRITICAL **: file gtkprogress.c: line 518 (gtk_progress_set_percentage):
assertion `percentage >= 0 && percentage <= 1.0' failed.

Gtk-CRITICAL **: file gtkprogress.c: line 518 (gtk_progress_set_percentage):
assertion `percentage >= 0 && percentage <= 1.0' failed.
_text): assertion
`GTK_IS_LABEL (label)' failed.




Keywords: nsbranch

Comment 10

17 years ago
Can someone try and repro this, and if you can, let's take a look at NOT doing a
Nav only install.

Comment 11

17 years ago
I can reproduce it with today's branch build.  Anybody else?
This sort of sounds like it turned into bug 97249, crashing on Linux when
choosing a "Custom" install. At first it sounded like a problem choosing the
"Browser only" option, which is probably different.
(Assignee)

Comment 13

17 years ago

*** This bug has been marked as a duplicate of 97249 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 14

17 years ago
verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 15

17 years ago
I downloaded the 9/27/01 nightly build and ran the installer with the following selections:1. Navigator Only2. Change directory3. Navigate to /tmp - using drop down menu in middle of dialog box4. Create Dir in /tmp 'moz-test'5. Click 'OK' on create directory button.6. Select 'moz-test' from 'Directories' list box in installer.7. Click 'OK' button8. Click 'Next' button9. Download Settings - Save installer modules upon download (not checked)10. Click 'install' button.When I run the installer like this:$ cd /tmp/mozilla-installer$  ./mozilla-installer-binThe installation files download and the installation results in the -618=Couldn't open xpistub library error message and quits.I also noticed that when I run the installer like this:$ cd /tmp/mozilla-installer$ ./mozilla-installer-binThe files are downloaded and installation completes without the -618 error - but mozilla hangs in the 'QFA startup' (and does not run - some other issue).For both installations, I still get several following assertion warnings to my terminal.  These occur _only_ when the QFA agent xpm is downloaded.  And it is because the listed total size of all xpi archives is not correct versus the actual sizes of each xpi archive.Gtk-CRITICAL **: file gtkprogress.c: line 518 (gtk_progress_set_percentage): assertion `percentage >= 0 && percentage <= 1.0' failed.Is the mozilla-installer/config.ini generated or what?  If it is generated, then the installer has another bug - it does not add the sizes of the 'Archive Size' attributes for the various xpi files in the config.iniThanks.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 16

17 years ago
what are the chances of this making the 0.9.4 branch?
Whiteboard: [Need ETA]

Comment 17

17 years ago
ok, reproduced by running ./mozilla-installer-bin instead of ./mozilla-installer
I got the -618 error -couldn't  open xpistub libraray
If I run ./mozilla-installer, I complete the install and launch - 
This is nightly build 2001100208


reporter, can you try running   the installer using ./mozilla-installer?
(Assignee)

Comment 18

17 years ago
Could the person who filed this retest? This should be fixed.

Comment 19

17 years ago
There has been no reponse from the reporter. Do we now this is Fixed | Verified?

Comment 20

17 years ago
I will verify if this is marked fixed- 
running ./mozilla-installer is the *right* thing to do and that works- we test 
regularly
(Reporter)

Comment 21

17 years ago
Sorry to delay in response.  I was out of the country for last two weeks.  
Will verify fix this weekend.
(Reporter)

Comment 22

17 years ago
Greetings.

I downloaded and installed the 0.9.5 build.  I ran the installer using the 
./mozilla-installer command and was able to install a 'navigator only' 
installation.  This bug is fixed.  Thanks for the hard work.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 23

17 years ago
Verified per reporter's comment.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.