Hardware home button needs to be tapped twice from landscape-secondary mode

RESOLVED FIXED

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: zac, Assigned: gasolin@mozilla.com)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.3 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR
1. Open an app that re-orientates to landscape (eg Browser)
2. Rotate device to landscape with power button on the left side
3. Press hardware home button (nothing happens)
4. Press again, homescreen appears


Device (any)
Gecko  http://hg.mozilla.org/mozilla-central/rev/16949049f03d
Gaia  cc9fec48957c9d217221d403aac4b5f35a826dd6
BuildID 20131110040200
Version 28.0a1

I don't have a regression range for this sorry as the range of steps on my dogfooding build is too great to be of value.
Keywords: regression, regressionwindow-wanted
Hardware: Other → ARM

Updated

5 years ago
QA Contact: sarsenyev

Comment 1

5 years ago
Regression Window:
The last working build on Buri 1.3 master build

Device: Buri 1.3 central
BuildID: 20131017040202
Gaia: 616e87af0133496620aea89f21ca5d37acedf466
Gecko: 423b9c30c73d
Version: 27.0a1
Firmware Version: US_20131104

The issue is started reproduce from:
Device: Buri 1.3
BuildID: 20131018040217
Gaia: 18c2ab4b7b2d4cacee90fb85e97354142b2fad4a
Gecko: 855da6d8a327
Version: 27.0a1
Firmware Version: US_20131104
Keywords: regressionwindow-wanted
Does this reproduce on 1.2?
blocking-b2g: --- → 1.3?
Keywords: qawanted

Updated

5 years ago
Component: Gaia::System::Lockscreen → Gaia::System::Window Mgmt

Comment 3

5 years ago
It does reproduce on the latest Buri 1.2 MOZ RIL
Needs to press twice on the "home" button in the landscape view to return to the home screen

Device: Buri 1.2 MOZ RIL
BuildID: 20131111004004
Gaia: 670b2c8329bca6f142939185be71274166d82bb8
Gecko: 1ac147e4e2f0
Version: 26.0
Firmware Version: US_20131104
Keywords: qawanted

Updated

5 years ago
blocking-b2g: 1.3? → koi?
Why is one extra tap a blocker? It's not awful user experience and can we live with this till 1.3?
(In reply to Preeti Raghunath(:Preeti) from comment #4)
> Why is one extra tap a blocker? It's not awful user experience and can we
> live with this till 1.3?

I don't agree that. The home button always pretty much has to work. Otherwise, that's a pretty crappy phone to ship that has a busted home button.
(Reporter)

Comment 6

5 years ago
(In reply to Preeti Raghunath(:Preeti) from comment #4)
> Why is one extra tap a blocker? It's not awful user experience and can we
> live with this till 1.3?

If you have the device one way up in landscape it's one tap, if you have it up the opposite way up in landscape it's two taps. Why the inconsistency?

It may not be an awful user experience but it's very scrappy.

Comment 7

5 years ago
triage marked koi+
blocking-b2g: koi? → koi+

Updated

5 years ago
Blocks: 908601
The regressing patch that caused this is bug 908601. This just got backed out of 1.2 today.

As such, we no longer need to block on this for 1.2, as the regressing patch was backed out of 1.2. Moving to 1.3+, as this issue only applies to master now.
blocking-b2g: koi+ → 1.3+
Taken
Assignee: nobody → alive
(Assignee)

Comment 10

4 years ago
steal it
Assignee: alive → gasolin
(Assignee)

Comment 11

4 years ago
Can reproduce on 1.3, but can't reproduce on master.
(Assignee)

Comment 12

4 years ago
Created attachment 8348531 [details] [review]
pull request redirect to github

overwrite 1.3 with master-gaia's AppWindow.determineClosingRotationDegree could fix this issue
Attachment #8348531 - Flags: review?(alive)
Attachment #8348531 - Flags: review?(alive) → review+
(Assignee)

Comment 13

4 years ago
merged to Gaia-1.3 https://github.com/mozilla-b2g/gaia/commit/dca0a3dcf062ce3e422a9c56d141c14543c816fb

It's 1.3 only bug, please don't merge to master
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-b2g-v1.3: --- → fixed
You need to log in before you can comment on or make changes to this bug.