[CSS] keyframes with zero (no units)

RESOLVED INVALID

Status

()

Firefox
Developer Tools: Style Editor
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: BaNru, Unassigned)

Tracking

({css3})

25 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131025151332

Steps to reproduce:

Not work animation in FireFox (In Chrome it works):

@keyframes slider {
	0 {top: 0px;}
	100% {top: 10px;}
}

or

@-moz-keyframes slider {
	0 {top: 0px;}
	100% {top: 10px;}
}



Expected results:

Work animation:

@keyframes slider {
	0% {top: 0px;}
	100% {top: 10px;}
}

or

@-moz-keyframes slider {
	0% {top: 0px;}
	100% {top: 10px;}
}
(Reporter)

Updated

4 years ago
Component: Untriaged → Developer Tools: Style Editor
Keywords: css3
Can't reproduce now. Please reopen if you can reproduce on latest Nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

4 years ago
(In reply to Girish Sharma [:Optimizer] from comment #1)
> Can't reproduce now. Please reopen if you can reproduce on latest Nightly.

http://demo.g63.ru/bugFF_animation.html

Left image animation - work
Right image animation - not work

Not Work 27.0.1 (Ubuntu) AND Not Work 30.0a1 (2014-03-16) (Nightly on Windows XP)
Okay, I see. The case I tested, simply ignored the 0 value and used the 100% as the final point.

Anyways, This is certainly not a bug, and definitely not a Style Editor bug. This is how keyframes are supposed to work according to the spec [0]. Chrome is just not following the spec correctly.

[0] http://www.w3.org/TR/css3-animations/#keyframe-selector
Resolution: WORKSFORME → INVALID
You need to log in before you can comment on or make changes to this bug.