If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

bmwmotorraeder.de - doesn't display anything useful - compare with IE

VERIFIED FIXED in Dec

Status

Tech Evangelism Graveyard
German
P1
major
VERIFIED FIXED
16 years ago
3 years ago

People

(Reporter: stephan, Assigned: Tristan Nitot)

Tracking

unspecified
x86
All

Details

(Whiteboard: [havefix], URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080104

just look at the page. It displays horizontal graphical bars, but no content and
no links.

Reproducible: Always
Steps to Reproduce:
1.open http://www.bmwmotorraeder.de/
2.thats it
3.
Gah.  This is a horribly obfuscated piece of DHTML.  At least one of the
problems involved here is the comments in the page: proper SGML comments begin
and end with "--", so the big strings of hyphens within comments are causing
much of the markup to be parsed as a comment.  Needs to be evangelized to get
them to fix their comments-replace "-" with "=", or some such.
Status: UNCONFIRMED → NEW
Ever confirmed: true
-> Evangelism
Assignee: asa → bclary
Component: Browser-General → Evangelism
QA Contact: doronr → zach

Comment 3

16 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 4

16 years ago
-> Euro
Assignee: bclary → nitot
Component: US English → European
QA Contact: zach → momoi

Comment 5

16 years ago
Moving to new component "West Europe".  European component is being removed. 
See bug 95808 for details.

Component: European → West Europe
QA Contact: momoi → caillon
Summary: doesn't display anything useful - compare with IE → bmwmotorraeder.de - doesn't display anything useful - compare with IE

Comment 6

16 years ago
Serious issue to view the site on NS.
As it is an important one, I put the priority to 1.
NS 6.2 200109290.
Priority: -- → P1
(Assignee)

Comment 7

16 years ago
Confirming with Moz 096. Os -> all
Got contact information from Compuserve Germany (Andreas Kagerer)
contact info is uwe.schmiedel@bmw.de
Sending first contact letter to Uwe, CC Andi.
Target -> december.
Status: NEW → ASSIGNED
OS: Linux → All
Target Milestone: --- → Dec

Comment 8

16 years ago
Problem: Bad browser detection and usage of document.all and document.layers

http://www.bmwmotorraeder.de/js/header.js

The Is() function that is used to create the "is" object detects Mozilla as NS4.

and

http://www.bmwmotorraeder.de/js/header.js [ look for function init() ]

<snip>
 if (is.ie) 
 {
   var layerRef = eval("document.all." + layerArray[i][0] + ".style");
 } 
 else
 {
   var layerRef = eval("document.layers." + layerArray[i][0]);
 }
</snip>

there might be other issues. Note that when I use Opera5 identifying as Opera or
Mozilla it also doesn't display any content. Only when I use Opera5 identifying
as IE5 it works. This is so because the content of the page is loaded with css
property "visibility: hidden;" and then made visible via javascript/DOM.
(Assignee)

Comment 9

16 years ago
excerpt from an IRC discussion with Basic : 
---
well to get it to work with moz the need to use document.getElementById("id")
rather than document.all.id. 
And their browser sniffing code needs updating and setting visibility: hidden
inline might not be such a good idea, I mean setting it in javascript via DOM
might be fine, but the way they do it currently will cause any browser that does
not have javascript or the right DOM or the right userAgent string to fails.
What I mean to say is that they should hide it only if they know that they can
show it via javascript ;-)
---

Updated

15 years ago
Whiteboard: [havefix]

Comment 10

15 years ago
WFM 2002081409 trunk win2k
*** Bug 140603 has been marked as a duplicate of this bug. ***

Comment 12

15 years ago
Agree with comment #10.

Same display in Mozilla and IE6.

Works for me, trunk build 2002082008 - WinXP

closing this bug as fixed - hope I do not make a mistake :-)

Reopen it if I made a mistake :-)
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 13

15 years ago
v
Status: RESOLVED → VERIFIED
move...
Component: Europe: West → German
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.