The new Firefox 25 find bar is a counter-productive ugly mess.

RESOLVED DUPLICATE of bug 935519

Status

()

Toolkit
Find Toolbar
--
enhancement
RESOLVED DUPLICATE of bug 935519
4 years ago
4 years ago

People

(Reporter: ahmet_ay1993, Unassigned)

Tracking

(6 keywords)

25 Branch
polish, ue, useless-UI, ux-discovery, ux-efficiency, ux-error-prevention
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131025151332

Steps to reproduce:

Updated to Firefox 25 from Firefox 24.


Actual results:

The Find Bar became a useless junk. First of all I guess in an effort to make it so that it covers less of the screen, buttons were slimmed. Read that again. The BUTTONS were slimmed not the actual bar. So the find bar covers the same space as always with unnecessarily smaller buttons. I sometimes miss clicking on the arrows because of this.

But that's only small fish compared to the biggest sin of this new bar. "Highlight All" and "Match Case" and the little "x" button to close the bar are all the way to the right while the search bar and the arrow buttons are all the way to the left. 
May I ask why? Seriously WHY?
When I'm using the find bar my mouse pointer is always on the bottom left since that's where I select the box to write and click buttons to navigate. With the old Find Bar the "Highlight All" and "Match Case" as well as the little "x" to close the bar was on the bottom left, right where my mouse pointer is. But now they are all the way to right to whenever I want to quickly open the bar up search something I close I have to move my mouse pointer all the way to the right. It is simply moronic.

Also there is the tab specific nature of this new bar. I can see that some people wanted this. Like there is this report:
https://bugzilla.mozilla.org/show_bug.cgi?id=537013

And understand why they've wanted it but I just hate it. It would be fine if it was optional but with it's current form it's only more busy work for me to open the Find Bar for every tab I want one by one.


Expected results:

I've expected a new update to NOT ruin something. I would have expected Mozilla to give options for a change like this in case, you know, somebody hates it with a passion.
(Reporter)

Updated

4 years ago
Keywords: ue, useless-UI
(Reporter)

Updated

4 years ago
Keywords: ux-discovery, ux-efficiency, ux-error-prevention
Whiteboard: Changes to the Find bar are not good.
(Reporter)

Updated

4 years ago
Severity: normal → enhancement
Keywords: polish
Component: Untriaged → Find Toolbar
Product: Firefox → Toolkit
Blocks: 565552
Keywords: polish, ue, useless-UI, ux-discovery, ux-efficiency, ux-error-prevention
OS: Windows XP → All
Hardware: x86 → All
Whiteboard: Changes to the Find bar are not good.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 935519
No longer blocks: 565552
You need to log in before you can comment on or make changes to this bug.