bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Mozilla fails to build on Linux/mips{,el}

RESOLVED FIXED

Status

SeaMonkey
Build Config
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: Ryan Murray, Assigned: cls)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Mozilla doesn't build on Linux/mips, failing with errors of the form:
/usr/lib/gcc-lib/mipsel-linux/2.95.4/crtbeginS.o(.text+0x4c): relocation
truncated to fit: R_MIPS_GOT16 __deregister_frame_info@@GLIBC_2.0

This is because the GOT16 table is too small.  It appears that NetBSD has
already run into this problem:
config/rules.mk:

ifeq ($(OS_ARCH),NetBSD)
ifneq (,$(filter arc cobalt hpcmips mipsco newsmips pmax sgimips,$(OS_TEST)))
ifeq ($(MODULE),layout)
OS_CFLAGS += -Wa,-xgot
OS_CXXFLAGS += -Wa,-xgot
endif
endif
endif

The same CFLAGS and CXXFLAGS are needed on Linux/mips and Linux/mipsel to solve
the problem.
(Assignee)

Comment 1

17 years ago
Created attachment 45538 [details] [diff] [review]
Add -Wa,-xgot to C{XX}FLAGS when building layout on Linux/mips{sel}
r=bryner
(Assignee)

Comment 3

17 years ago
Patch has been checked in.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.