mapi broken (cant send files to emails via explorer, shell) in (german) seamonkey 2.22 (sm 2.21 works fine, doublechecked)

RESOLVED DUPLICATE of bug 913493

Status

SeaMonkey
OS Integration
--
major
RESOLVED DUPLICATE of bug 913493
5 years ago
5 years ago

People

(Reporter: abittner, Unassigned)

Tracking

SeaMonkey 2.22 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.101 Safari/537.36

Steps to reproduce:

(double checked this issue, i am not a noob)

running seamonkey on win32 (winxp 32bit, german, professional) with little trouble for many years. suddenly cannot rightclick files and send to mail recipient any more. the email composition window with the file attached does not appear any more. instead only the main seamonkey start/home browser window appears and the windows system log logs dcom errors, that it could not register 29F458BE-8866-11D5-A3DD-00B0D0F3BAA7 with dcom. looked on the net and eventually found this thread: http://forums.mozillazine.org/viewtopic.php?f=5&t=495173

i have all the registry keys given there and i also reregistered those two dll files given in the thread the mozmapi (mozilla) and the sendmail (microsoft?) dll, but this doesnt help at all.

the seamonkey.exe gets started with the proper parameters, both with seamonkey 2.21 and 2.22 ( "C:\Programme\SeaMonkey\seamonkey.exe" /MAPIStartup -Embedding ) by the svchost.exe process that is the dcom task, I doublechecked with processexplorer and similar tools, so far so good.

using the seamonkey 2.21 installer and downgrading over my 2.22 folder immediately renders the seamonkey (2.21 then) usable and rightclick send files to email recipient immediately works again normally, the seamonkey main window (browser) and the seamonkey email composition window with the appropriate file already loaded into attachment gets displayed as well.

when upgrading to seamonkey 2.22 via downloaded .exe installer again, it immediately gets borked and hosed again :(

double and triple checked all of this.

the mozillazine thread speaks about badly linking or building the mozmapi dll to bad msvcrt libraries and sort of this think, although i am not an expert to know if this is really the problem again (that mozillazine thread is ancient)

https://bugzilla.mozilla.org/show_bug.cgi?id=359885
https://bugzilla.mozilla.org/show_bug.cgi?id=366719
https://bugzilla.mozilla.org/show_bug.cgi?id=368952

thanks for fixing this really quickly.
regards.
(Reporter)

Updated

5 years ago
Severity: normal → major

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 913493

Comment 2

5 years ago
For reference, http://forums.mozillazine.org/viewtopic.php?f=40&t=2765021 is a more recent thread on MZ, specifically dealing with the current issue.
You need to log in before you can comment on or make changes to this bug.