If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Underline of linked text disappears at certain CSS font size settings

RESOLVED DUPLICATE of bug 392785

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 392785
16 years ago
7 years ago

People

(Reporter: doctor__j, Unassigned)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.3+) Gecko/20010804
BuildID:    2001080411

Reproducible: Always
Steps to Reproduce:
1. Load the testcase.
2. Select the line as indicated in the testcase.
3. Upon selection, the underline of the linked text above the current selected
line disappeared.
4. Select the unlinked text, which is at the same line as the linked text, from
the right side and extend the selection to cover the linked text to make the
underline of the linked text to reappear.

Expected Results:  Selection of any text should not make the underline of linked
text disappear.

The effect doesn't happens on every font size settings.  Maybe it's some
approx/round-off error in redrawing the underline?
(Reporter)

Comment 1

16 years ago
Created attachment 44717 [details]
Testcase - Repro instruction included inside testcase.

Comment 2

16 years ago
I can't seem to repro this using a trunk build from 8/9/01 on win98 -- Terri,
can you repro this?

Comment 3

16 years ago
cant see this sorry
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 4

16 years ago
Verified WFM
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

16 years ago
I can still see it on Win32 build 2001120703.
Just select a word in the line "1. Performing text selection in this line..."
and you will see the underline of the link above disappear.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 6

16 years ago
marking future
Target Milestone: --- → Future

Comment 7

16 years ago
you can see this in full effect in links at the bottom of this page:
http://www.thegoldenear.connectfree.co.uk/gg/

with:
'thegoldenear-at-connectfree-dot-co-dot-uk'
'http://www.thegoldenear.connectfree.co.uk/'

I see it with 2002021903 and many more going way back

Comment 8

16 years ago
sorry for the spam. too early in the morning. this bug probably isn't
appropriate to what I commented about as this bug is about selecting text
where-as what I'm seeing is a plain rendering issue

Comment 9

14 years ago
*** Bug 218876 has been marked as a duplicate of this bug. ***
Assignee: mjudge → nobody
QA Contact: tpreston → selection
This should be fixed by bug 392785.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago7 years ago
Component: Selection → Layout: Text
QA Contact: selection → layout.fonts-and-text
Resolution: --- → DUPLICATE
Duplicate of bug: 392785
You need to log in before you can comment on or make changes to this bug.