Iframe is not reflowing properly as the window scrolls

RESOLVED DUPLICATE of bug 76085

Status

()

Core
Layout: HTML Frames
--
minor
RESOLVED DUPLICATE of bug 76085
17 years ago
17 years ago

People

(Reporter: Emlyn Shannon, Assigned: Eric Pollmann)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
Using 0.9.3 milestone on mac 0S 9....

smh.com.au uses an Iframe to load a contant header to every one of its pages.
When the window is scrolled, the iframe area is not refreshed as it should be -
instead, parts of the iframe area are duplicated, so that it looks like a bunch
of vertical lines (or some vertical lines and text, depending on how fast you
want to scroll). Loading the src of the Iframe by itself
(http://images.ads.fairfax.com.au/cui/SMH.html) causes no problems.

The iframe is always reflowed properly (eg, on mouseover, or when the animated
gif changes) except when scrolled.

Smh.com is a fairly big site for australian audiences, and while this bug
doens't make it unnavigable, it does make it less pretty.



Reproducible: Always
Steps to Reproduce:
1.Navigate to http://smh.com.au/
2.Scroll down
3.Scroll up
4.Inspect the black thingy at the very top of the window. Note that it doesn't
look the same as it did before you scrolled down.

Actual Results:  The iframe was drawn badly, in overlapping copies of itself.

Expected Results:  The iframe should be drawn properly when scrolled.

Comment 1

17 years ago
Confirmed using Mac/2001080214 under Mac OS 9.1 A screenshot (to be attached) shows 
visual cruft left behind after dragging the vertical scrollbar elevator down an inch or so, 
then back up.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
Created attachment 44826 [details]
Screenshot of URL in question showing visual cruft left after scroll elevator dragging.

Comment 3

17 years ago
Created attachment 44830 [details]
Screenshot of URL in question showing visual cruft left after scroll elevator dragging.

Comment 4

17 years ago
Created attachment 44833 [details]
Minimized testcase exhibiting problem

Comment 5

17 years ago
Newly attached testcase demonstrates the problem using a minimum of HTML. It is the 
combination of a 100% width and no frameborders that results in the problem occurring. 
Load the testcase and drag the scrollbar elevator down. You'll see the bottom of the 
black-backgrounded IFRAME scroll up, but the text at top remains stationary.

The problem occurs regardless of the URL value of the SRC attribute.

(Another, probably unrelated, problem observed is that if the SRC value is changed to 
another URL and the page reloaded, Mozilla continues to use the old SRC value, even as 
the new value is visible in the View Source window.)

Comment 6

17 years ago
dupe of 76085

*** This bug has been marked as a duplicate of 76085 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.