Several OF platform filters don't work

RESOLVED FIXED

Status

Tree Management
OrangeFactor
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: jgriffin, Assigned: jgriffin)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
The following platform filters produce 0 results:

Ubuntu (VM)
B2G
B2G (VM)

Presumably, some magic config strings are in need of changing.

We should fix this, and add support for the new b2g-desktop platforms.
(Assignee)

Comment 1

4 years ago
Created attachment 830477 [details] [diff] [review]
Update platform list,
Attachment #830477 - Flags: review?(mcote)
(Assignee)

Updated

4 years ago
Assignee: nobody → jgriffin
(Assignee)

Comment 2

4 years ago
Notably, this patch removes the 'ubuntu' platform (as a distinct platform from 'linux') since TBPL doesn't recognize them as different.  It also removes the obsolete OSX 10.5 platform, and completely refactors the B2G platforms according to how TBPL currently uses them.

Comment 3

4 years ago
Comment on attachment 830477 [details] [diff] [review]
Update platform list,

Review of attachment 830477 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine though I am not well acquainted with the current systems.

::: html/scripts/woo.utils.js
@@ +36,5 @@
> +      "b2g-win32": "B2G Desktop Windows",
> +      "b2g-emu-ics": "B2G ICS Emulator",
> +      "b2g-emu-jb": "B2G JB Emulator",
> +      "b2g-device-image" : "B2G Device Image",
> +      "other": "Other"

Might as well stick with single quotes to match everything else.
Attachment #830477 - Flags: review?(mcote) → review+
(Assignee)

Comment 5

4 years ago
deployed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Product: Testing → Tree Management
You need to log in before you can comment on or make changes to this bug.