High CPU load (>100%) in MediaDecoderStateMachine after loading the given web page

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
--
major
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

26 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 830458 [details]
profile.txt

I got a link today which caused my Firefox instance to use more than 100% of CPU load on my quad core box. Peak was around 240% for a couple of seconds. I did a sysprof run and exported the profile. As it looks like most of the time is spent in MediaDecoderStateMachine. Interestingly no media file is getting played when loading the page.
This may be related to bug 933856.
Keywords: regressionwindow-wanted
Henrik, can you tell if this is a dupe of bug 933856?
see comment 2
Flags: needinfo?(hskupin)
Component: Audio/Video → Audio/Video: Playback
(Reporter)

Comment 4

2 years ago
Sorry for responding that late. I totally missed the ni request. I think at the time when it happened it was an ad which was displayed. There is no way to reproduce this bug anymore and given that there is no minimized testcase available I cannot say for sure if it is a dupe. So I mark it as WFM.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(hskupin)
Resolution: --- → WORKSFORME
(Reporter)

Updated

2 years ago
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.