If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[1.2/1.3] Screen stays black after tapping the power button, lights up only after first subsequent UI update

RESOLVED FIXED

Status

Firefox OS
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: nhirata, Assigned: fabrice)

Tracking

(Blocks: 1 bug, {regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:koi+, firefox27 fixed, b2g-v1.2 fixed, b2g-v1.3 unaffected)

Details

Gaia   f7b408fe7e40a6e783e3f29c5cea5ec5ba5349ae
SourceStamp 70f21fad60a4
BuildID 20131108040203
Version 28.0a1
Helix

1. install OEM build, flash gecko/gaia as per above.
2. let the device sleep
3. tap the power to wake it

Expected: lockscreen appears
Actual: the screen is still all black, if you swipe where the lock is located to unlock the device the device will wake and unlock
blocking-b2g: --- → 1.3?
Keywords: regression, regressionwindow-wanted

Updated

4 years ago
QA Contact: sparsons

Comment 1

4 years ago
This issue started to occur on the Helix 1.2 Build ID: 20130916040205

Gaia   a0079597d510ce8ea0b9cbb02c506030510b9eeb
SourceStamp c4bcef90cef9
BuildID 20130916040205
Version 26.0a1

Last Working Helix 1.2 Build ID: 20130915040205

Gaia   3f51f302c3a0c57d8bad482ec7ee86b2819389fb
SourceStamp 9366ee039645
BuildID 20130915040205
Version 26.0a1
Keywords: regressionwindow-wanted
Helix is target on v1.1, we don't expect it can run on v1.2 or v1.3. 
There is a bug 933711 on v1.1 that look like a dup of this.
blocking-b2g: 1.3? → hd?
Component: Gaia::System::Lockscreen → General
Flags: needinfo?(sparsons)
I take it the question being asked here is to check if this reproduces on 1.1.
Keywords: qawanted

Comment 4

4 years ago
This issue does not reproduce on Helix 1.1HD Build ID: 20131119042200

Gaia   85f9a33cc95e04f5fd962ec37fa39eb622136f45
SourceStamp fa03d0230e50
BuildID 20131119042200
Version 18.0
Flags: needinfo?(sparsons)
Keywords: qawanted
Moving back to 1.3? as this bug is a regression to 1.3
blocking-b2g: hd? → 1.3?
Can someone check if this reproduces on 1.2?
Keywords: qawanted

Comment 7

4 years ago
This issue also reproduces on Buri 1.2 Build ID: 20131119004006

Gaia   9439907a255e04de4c33493fe03d6670c8256e2f
SourceStamp fe2a7f0db27b
BuildID 20131119004006
Version 26.0
Keywords: qawanted

Updated

4 years ago
blocking-b2g: 1.3? → koi?

Updated

4 years ago
blocking-b2g: koi? → koi+
Blocking on this for blocking a critical use case of the power button of the phone
This also reproduces in Ikura V1.2 Build ID: 20131114004004
mwu - Do you have any ideas what could cause a bug like this? Could it be a gaia, gecko, or gonk bug?
Flags: needinfo?(mwu)
(In reply to Juan Perez-Bedmar [:juanpbf] @ Madrid from comment #9)
> This also reproduces in Ikura V1.2 Build ID: 20131114004004

Adding dep for 1.2 pre-testing.
Blocks: 943796

Comment 12

4 years ago
Can we get a logcat when this occurs?

Comment 13

4 years ago
Add qawanted to help getting a logcat.
Keywords: qawanted

Comment 14

4 years ago
I can no longer repro this issue on the Helix 1.3 Build ID: 20131205040201

Gaia   1dd0e5c644b4c677a4e8fa02e50d52136db489d9
SourceStamp 725c36b5de1a
BuildID 20131205040201
Version 28.0a1
Tim, this might be already fixed, but can you assign an engineer to confirm on Helix?
Component: General → Gaia::System::Lockscreen
Flags: needinfo?(timdream)
(In reply to Sarah Parsons from comment #14)
> I can no longer repro this issue on the Helix 1.3 Build ID: 20131205040201
> 
> Gaia   1dd0e5c644b4c677a4e8fa02e50d52136db489d9
> SourceStamp 725c36b5de1a
> BuildID 20131205040201
> Version 28.0a1

Does it still reproduce on 1.2?

Updated

4 years ago
Flags: needinfo?(mwu)
This is not a lock screen issue but rather a Helix-specific porting issue, AFAIK. Please do not switch the component back to lock screen again.

QA, please try to reproduce this on v1.2 and loop graphic/system engineers.

Marco, is this issue already under the radar?
Component: Gaia::System::Lockscreen → General
Flags: needinfo?(timdream) → needinfo?(mchen)
Summary: [helix][1.3] lockscreen stays black after tapping the power button in order to wake the device → [helix][1.2] screen stays black after tapping the power button, lights up only after first subsequent UI update
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #17)
> This is not a lock screen issue but rather a Helix-specific porting issue,
> AFAIK. Please do not switch the component back to lock screen again.
> 
> QA, please try to reproduce this on v1.2 and loop graphic/system engineers.
> 
> Marco, is this issue already under the radar?

It's not Helix-specific. comment 7 already confirmed this also reproduces on Buri 1.2.

Comment 19

4 years ago
This issue still reproduces on the Helix 1.2 Build ID: 20131206004002

Gaia   d48df33cbdae2063f12b09e3dca07ff7a2f2a3cc
SourceStamp fd0302696c57
BuildID 20131206004002
Version 26.0
Keywords: qawanted

Comment 20

4 years ago
I am unable to get a logcat because the logcat stops recording when the phone goes to sleep which is a required step.

(In reply to Sarah Parsons from comment #19)
> This issue still reproduces on the Helix 1.2 Build ID: 20131206004002
> 
> Gaia   d48df33cbdae2063f12b09e3dca07ff7a2f2a3cc
> SourceStamp fd0302696c57
> BuildID 20131206004002
> Version 26.0
(In reply to Sarah Parsons from comment #19)
> This issue still reproduces on the Helix 1.2 Build ID: 20131206004002
> 
> Gaia   d48df33cbdae2063f12b09e3dca07ff7a2f2a3cc
> SourceStamp fd0302696c57
> BuildID 20131206004002
> Version 26.0

I guess what that means is that some patch on trunk fixed this bug, but wasn't uplifted to 1.2.
Let's try getting a reverse regression window here. What that means is:

Find out when this started working on 1.3 & the last time it failed on 1.3.
Keywords: regressionwindow-wanted

Comment 23

4 years ago
The last broken build was Helix 1.3 Build ID: 20131128040201

Gaia   0d57ec2801ae125ec855a19cf956ab118660d694
SourceStamp a5e7f611546f
BuildID 20131128040201
Version 28.0a1

First build the issue stopped occurring was Helix 1.3 Build ID: 20131129053350

Gaia   09d1f63762aaf645b5b6642d218b40f069b77562
SourceStamp e9337081c744
BuildID 20131129053350
Version 28.0a1
Keywords: regressionwindow-wanted
This was likely fixed by Re-Implementation of the Lockscreen in bug 919410 for 1.3.
(In reply to Jason Smith [:jsmith] from comment #24)
> This was likely fixed by Re-Implementation of the Lockscreen in bug 919410
> for 1.3.

Actually, that doesn't look right. That bug isn't part of the Gaia regression range.
Reverse Regression Range Push Log:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a5e7f611546f&tochange=e9337081c744
(In reply to Jason Smith [:jsmith] from comment #26)
> Reverse Regression Range Push Log:
> 
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=a5e7f611546f&tochange=e9337081c744

Hmm...this is going to be hard diagnose based on looking at the push log.

Can someone get a logcat when this bug reproduces?
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #27)
> (In reply to Jason Smith [:jsmith] from comment #26)
> > Reverse Regression Range Push Log:
> > 
> > http://hg.mozilla.org/mozilla-central/
> > pushloghtml?fromchange=a5e7f611546f&tochange=e9337081c744
> 
> Hmm...this is going to be hard diagnose based on looking at the push log.
> 
> Can someone get a logcat when this bug reproduces?

Just realized logcat isn't possible, since logcat is disabled when the screen is locked.
Keywords: qawanted

Updated

4 years ago
Summary: [helix][1.2] screen stays black after tapping the power button, lights up only after first subsequent UI update → [1.2/1.3] Screen stays black after tapping the power button, lights up only after first subsequent UI update

Comment 29

4 years ago
Hi, Naoki-san,

Sorry. I changed the title because the bug not only happened on helix but also can reproduce on other devices.
If you feel it is inappropriate, please feel free to change it.
Many thanks.
Might be related to bug 920804? In the bug 933711, I resolve similar issue by back-porting bug 920804.

Comment 31

4 years ago
Thanks for Morris's update.

The patch landed to master (v1.3) and uplifted to 1.1.0hd already.
Flags: needinfo?(mchen)

Comment 32

4 years ago
Because 1.2 is going to be finished, should we mark this bug from koi+ to 1.3+? Thanks.
(In reply to Kevin Hu [:khu] from comment #32)
> Because 1.2 is going to be finished, should we mark this bug from koi+ to
> 1.3+? Thanks.

Hi, 

I think this is quite serious issue, I'd keep koi+ (not moving to 1.3)... 

Thnks!
David
(In reply to Marco Chen [:mchen] from comment #31)
> Thanks for Morris's update.
> 
> The patch landed to master (v1.3) and uplifted to 1.1.0hd already.

Note - the combination of both of those patches don't match the regression range above. bug 920804 landed on 10/26/2013 & bug 933070 landed on 11/5/2013. The regression range indicates this would have been fixed by something that landed on 11/28/2013.
(Assignee)

Comment 35

4 years ago
yes, we should backport bug 920804 and bug 933070 to 1.2, since they only landed on gecko27 and 28.

Updated

4 years ago
Depends on: 920804

Updated

4 years ago
Depends on: 933070
(Assignee)

Comment 36

4 years ago
Try run with the patches rebased:

https://tbpl.mozilla.org/?tree=Try&rev=a79bf7a7a488
(Assignee)

Comment 37

4 years ago
... and this one at least compiled locally:

https://tbpl.mozilla.org/?tree=Try&rev=958d79598ba9
(Assignee)

Comment 38

4 years ago
I pushed both to b2g26:
remote:   https://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/cd6aa18208e6
remote:   https://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/8f277371699d
(In reply to Fabrice Desré [:fabrice] from comment #38)
> I pushed both to b2g26:
> remote:   https://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/cd6aa18208e6
> remote:   https://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/8f277371699d

Should we close this out if this is landed on b2g26?
Per Fabrice, This was backported 3 days ago, should be fixed now.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-b2g-v1.2: --- → fixed
status-b2g-v1.3: --- → unaffected
status-firefox27: --- → fixed
Assignee: nobody → fabrice
You need to log in before you can comment on or make changes to this bug.