Closed Bug 937427 Opened 8 years ago Closed 8 years ago

Can't run mochitests on real B2G device

Categories

(Testing :: Mochitest, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 915810

People

(Reporter: jgriffin, Unassigned)

Details

When attempting to run B2G mochitests on a real device, there are lots of devicemanager- and mozrunner-related errors, e.g.,

Mochitest INFO | runtestsb2g.py | Running tests: start.
remount succeeded
B2GRunner INFO | waiting for device to come back online after reboot
Traceback (most recent call last):
  File "/usr/lib/python2.7/logging/__init__.py", line 846, in emit
    msg = self.format(record)
  File "/usr/lib/python2.7/logging/__init__.py", line 723, in format
    return fmt.format(record)
  File "/home/jgriffin/mozilla-inbound/src/testing/mozbase/mozlog/mozlog/logger.py", line 117, in format
    record.message = record.getMessage()
  File "/usr/lib/python2.7/logging/__init__.py", line 328, in getMessage
    msg = msg % self.args
TypeError: not all arguments converted during string formatting
Logged from file remote.py, line 226
Traceback (most recent call last):
  File "runtestsb2g.py", line 137, in run_tests
    self.runner.start(outputTimeout=timeout)
  File "/home/jgriffin/mozilla-inbound/src/testing/mozbase/mozrunner/mozrunner/remote.py", line 132, in start
    if not self._wait_for_net():
  File "/home/jgriffin/mozilla-inbound/src/testing/mozbase/mozrunner/mozrunner/remote.py", line 252, in _wait_for_net
    proc.stdout.readline() # ignore first line
AttributeError: 'NoneType' object has no attribute 'readline'
Mochitest ERROR | Automation Error: Received unexpected exception while running application

B2GRunner INFO | checking for crashes in '/data/local/tests/profile/minidumps'
lo       UP                                   127.0.0.1/8   0x00000049 00:00:00:00:00:00
rmnet0   DOWN                                   0.0.0.0/0   0x00000000 00:00:00:00:00:00
rmnet1   DOWN                                   0.0.0.0/0   0x00000000 00:00:00:00:00:00
rmnet2   DOWN                                   0.0.0.0/0   0x00000000 00:00:00:00:00:00
rmnet3   DOWN                                   0.0.0.0/0   0x00001002 76:ca:c2:17:01:04
rmnet4   DOWN                                   0.0.0.0/0   0x00001002 4a:7e:ac:68:6a:c1
rmnet5   DOWN                                   0.0.0.0/0   0x00001002 8e:94:52:dc:82:6a
rmnet6   DOWN                                   0.0.0.0/0   0x00001002 22:51:b8:63:a3:28
rmnet7   DOWN                                   0.0.0.0/0   0x00001002 da:e9:4e:46:a1:a0
tunl0    DOWN                                   0.0.0.0/0   0x00000080 00:00:00:00:00:00
sit0     DOWN                                   0.0.0.0/0   0x00000080 00:00:00:00:00:00
ip6tnl0  DOWN                                   0.0.0.0/0   0x00000080 00:00:00:00:00:00
wlan0    DOWN                                   0.0.0.0/0   0x00001002 f8:df:a8:0b:35:9a

I suspect mozrunner's remote.py hasn't been tested against real devices.
Duping this bug as there is a WIP patch in the other one. I think the patch there will fix the devicemanager/mozrunner errors, but I still ran into problems after that and never got around to fixing it completely.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 915810
You need to log in before you can comment on or make changes to this bug.