Make cloneNode/importNode with the "deep" arg not passed default to shallow cloning

RESOLVED FIXED in mozilla29

Status

()

defect
RESOLVED FIXED
6 years ago
a month ago

People

(Reporter: bzbarsky, Assigned: bzbarsky)

Tracking

({addon-compat, dev-doc-complete, site-compat})

unspecified
mozilla29
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Fallout from https://www.w3.org/Bugs/Public/show_bug.cgi?id=23565

I'll file a bunch of bugs blocking this one on getting people off the API we're about to break.
Depends on: 937462
Keywords: dev-doc-needed
Depends on: 937465
Depends on: 937468
Depends on: 937470
Depends on: 937474
Keywords: addon-compat
Depends on: 937476
Assignee: nobody → bzbarsky
Status: NEW → ASSIGNED
Ms2ger, note the imptests change
Attachment #8347836 - Flags: review?(jonas)
Attachment #8347836 - Flags: review?(Ms2ger)
Attachment #8347575 - Attachment is obsolete: true
Attachment #8347575 - Flags: review?(jonas)
Whiteboard: [need review from Ms2ger]
Comment on attachment 8347836 [details] [diff] [review]
Make cloneNode/importNode "deep" arg default to false, since the spec changed on us.

Review of attachment 8347836 [details] [diff] [review]:
-----------------------------------------------------------------

https://github.com/w3c/web-platform-tests/pull/473
Attachment #8347836 - Flags: review?(Ms2ger) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/c59accdc321a
Flags: in-testsuite+
Whiteboard: [need review from Ms2ger]
Target Milestone: --- → mozilla29
https://hg.mozilla.org/mozilla-central/rev/c59accdc321a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.