[Fugu][Buri][Browser] null item appears in image context menu

RESOLVED FIXED

Status

Firefox OS
Gaia::Browser
P1
normal
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: Peipei Cheng (needinfo if you need my action), Assigned: Evelyn Hung)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Created attachment 830681 [details]
Browser image context menu

Firefox OS V1.2
Test build: 20131110004003
gecko: 8926376583fdd3711aaf75594fd4084306c5f02a
gaia: 3cc5e6ddec0656b3a6a197e989dabebee536c982


1. Launch Browser
2. Go to http://m.sohu.com
3. Long tap on the picture of this website
   [issue] The first item in the context menu is empty. Please see attached screenshot.
Priority: -- → P1
blocking-b2g: --- → koi?
(In reply to pcheng from comment #0)
> Created attachment 830681 [details]
> Browser image context menu
> 
> Firefox OS V1.2
> Test build: 20131110004003
> gecko: 8926376583fdd3711aaf75594fd4084306c5f02a
> gaia: 3cc5e6ddec0656b3a6a197e989dabebee536c982
> 
> 
> 1. Launch Browser
> 2. Go to http://m.sohu.com
> 3. Long tap on the picture of this website
>    [issue] The first item in the context menu is empty. Please see attached
> screenshot.

The item in the context menu that is empty should say save image.

QA Wanted - Can someone else confirm reproducibility on 1.2 & check to see if it reproduces on 1.1 or not? Also, can you get a logcat?
Keywords: qawanted
Created attachment 8335180 [details]
adblogcat_V1.2

Attached is the adb logcat for V1.2
Timestamp: 11-20 04:21:14.589

Note: 
1. This issue only exists for m.sohu.com. For other websites, the context menu is rendered correctly.
2. I tested on V1.1, no context menu appears.

To reproduce:
Long tap on any image on website m.sohu.com
Here is a link which has pictures: (http://m.sohu.com/c/5933/?_once_=000025_top_tuku_v2&_smuid=0vHcLW4I1mC0aH205enB43&v=2)


Test Builds:
Hamachi V1.1 build
Gaia:     b585b32441fafa67f2b4582db23be5f3a2afab21                           
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/7c3cfc0936ca      
BuildID   20131119041201                                                      
Version   18.0 

Hamachi V1.2 build
Gaia:     9439907a255e04de4c33493fe03d6670c8256e2f                           
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/fe2a7f0db27b  
BuildID   20131119004006                                                      
Version   26.0

Updated

4 years ago
Keywords: qawanted
Renom if partner specifically asks for this.

It seems website specific at this point and hence minus
blocking-b2g: koi? → -

Updated

4 years ago
Flags: needinfo?(ehung)

Updated

4 years ago
blocking-b2g: - → fugu?
(Assignee)

Comment 4

4 years ago
Created attachment 8342252 [details] [review]
one line fix: a wrong variable reference.

The problem happens because we can't get correct l10n id, because of a wrong variable reference.
so just one line fix: use uppercase node name to map l10n id.
Attachment #8342252 - Flags: review?(bfrancis)
Flags: needinfo?(ehung)
(Assignee)

Updated

4 years ago
Assignee: nobody → ehung
Comment on attachment 8342252 [details] [review]
one line fix: a wrong variable reference.

Thanks Evelyn :)
Attachment #8342252 - Flags: review?(bfrancis) → review+
(Assignee)

Comment 6

4 years ago
merged into gaia master: https://github.com/mozilla-b2g/gaia/commit/c7c9167d2243dc7425e34651599878fd5a528541
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Mass-modify - removal of no longer relevant blocking flags.

Updated

3 years ago
blocking-b2g: fugu? → ---
You need to log in before you can comment on or make changes to this bug.