The list is going up 2 levels when pressing back button in the bookmark folders

VERIFIED FIXED in Firefox 26, Firefox OS v1.2

Status

()

Firefox for Android
Awesomescreen
VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: Flaviu Cos, Assigned: lucasr)

Tracking

({reproducible})

Trunk
Firefox 28
ARM
Android
reproducible
Points:
---

Firefox Tracking Flags

(firefox25 unaffected, firefox26+ verified, firefox27 verified, firefox28 verified, b2g-v1.2 fixed, fennec26+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Environment: 
Device: Asus Transformer Tab (Android 4.0.3)
Build: Nightly 28.0a1 (2013-11-11)

Steps to reproduce:
1. Sync fennec with a pc.
2. Wait until all the bookmarks are imported from the synced device.
3. From the awesomescreen tap on the bookmarks.
4. Tap on 'Desktop Bookmarks' folder.
5. Tap on 'Bookmarks Menu' folder.
6. Tap on 'Mozilla Firefox' folder.
7. Tap the android back button.

Expected result:
The list is going up one level.

Actual result:
When tapping android back button the list is going up 2 levels.
(Reporter)

Updated

5 years ago
status-firefox25: --- → unaffected
status-firefox26: --- → affected
status-firefox27: --- → affected
status-firefox28: --- → affected

Updated

5 years ago
tracking-fennec: --- → ?
I can not reproduce this in today's trunk build on a HTC One X+ Android 4.3, Sony Tablet S Android 4.0 and a 2013 Nexus 7 Android 4.3.
(Reporter)

Comment 2

5 years ago
I borrowed the following devices from my colleagues:
Htc One X (Android 4.1.1);
Sony Tablet S (Android 4.0.3);
Nexus 7 (Android 4.3);
The bug is reproducible on every of the mentioned devices.
Please check this video: http://www.youtube.com/watch?v=anKtuau0BII

Updated

5 years ago
tracking-firefox26: --- → ?
Hm, yes now I can reproduce.

Updated

5 years ago
Keywords: reproducible
Assignee: nobody → lucasr.at.mozilla
tracking-fennec: ? → 26+
Do we have a regression range here? Is this a recent regression? Not sure we need to track or just be open to a low risk uplift nomination if available within the week (as we are nearing end of 26 beta)
Keywords: regressionwindow-wanted

Updated

5 years ago
Flags: needinfo?(flaviu.cos)
(Reporter)

Comment 5

5 years ago
Good build 08.21.2013;
Bad build 08.22.2013;
Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d136c8999d96&tochange=2ab07dec6404
Tested on Google Nexus 10 (Android 4.3).
Flags: needinfo?(flaviu.cos)
Keywords: regressionwindow-wanted
fig branch merge to mozilla-central with dozens of changesets. Sriram, or Lucas, do you need a bi-sect from that?
(Assignee)

Comment 7

5 years ago
(In reply to Aaron Train [:aaronmt] from comment #6)
> fig branch merge to mozilla-central with dozens of changesets. Sriram, or
> Lucas, do you need a bi-sect from that?

Not sure it would be trivial to do given how many broken state we had while developing in fig. I'll debug it manually.
This shipped in FF24 & FF25 so it's not a recent regression to the point that we'd take a late landing for it.  It's not ideal user experience but can probably ride the trains one more release (nominate uplift to Aurora FF27 if low risk fix available in time).
tracking-firefox26: ? → -
(In reply to lsblakk@mozilla.com [:lsblakk] from comment #8)
> This shipped in FF24 & FF25 so it's not a recent regression to the point
> that we'd take a late landing for it.  It's not ideal user experience but
> can probably ride the trains one more release (nominate uplift to Aurora
> FF27 if low risk fix available in time).


What? This is new to 26.

Updated

5 years ago
tracking-firefox26: - → ?
(In reply to Aaron Train [:aaronmt] from comment #9)
> (In reply to lsblakk@mozilla.com [:lsblakk] from comment #8)
> > This shipped in FF24 & FF25 so it's not a recent regression to the point
> > that we'd take a late landing for it.  It's not ideal user experience but
> > can probably ride the trains one more release (nominate uplift to Aurora
> > FF27 if low risk fix available in time).
> 
> 
> What? This is new to 26.

My mistake, confusing good/bad builds on nightly with releases.  I see, thanks - let's find the broken patchset and see if a backout is an option at this stage.
tracking-firefox26: ? → +
(Assignee)

Comment 11

5 years ago
Created attachment 8335953 [details] [diff] [review]
Only handle BACK key on ACTION_UP in Bookmarks page (r=mfinkle)
(Assignee)

Updated

5 years ago
Attachment #8335953 - Flags: review?(mark.finkle)
Attachment #8335953 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 13

5 years ago
Comment on attachment 8335953 [details] [diff] [review]
Only handle BACK key on ACTION_UP in Bookmarks page (r=mfinkle)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new about:home (bug 862793)
User impact if declined: Bookmark navigation with Android's BACK button feels broken.
Testing completed (on m-c, etc.): Just pushed to fx-team. Let's bake this in Nightly for a couple days and then uplift to Aurora/Beta. 
Risk to taking this patch (and alternatives if risky): Low, very trivial change.
String or IDL/UUID changes made by this patch: n/a
Attachment #8335953 - Flags: approval-mozilla-beta?
Attachment #8335953 - Flags: approval-mozilla-aurora?
Triage drive by, next Monday is the go-to-build for mobile beta so we'll check back before then.
https://hg.mozilla.org/mozilla-central/rev/9aa627b04ef3
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28

Updated

5 years ago
Flags: needinfo?(flaviu.cos)
Keywords: verifyme

Updated

5 years ago
Attachment #8335953 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 16

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/8e85dacac5de
status-firefox27: affected → fixed
status-firefox28: affected → fixed
Please consolidate your pushes to Aurora in the future. Doing separate pushes leads to a lot of extra jobs being run and we're already hurting for Tegra capacity. Thanks :)
(Reporter)

Comment 18

5 years ago
Verified as fixed in build: Nightly 28.0a1 (2013-11-22).
Device: Asus Transformer Tab (Android 4.0.3)
status-firefox28: fixed → verified
Flags: needinfo?(flaviu.cos)
Keywords: verifyme
(Reporter)

Comment 19

5 years ago
The bug is still reproducible on build: Aurora 27.0a2 (2013-11-22).
Device: Asus Transformer Tab (Android 4.0.3)
(Assignee)

Comment 20

5 years ago
(In reply to flaviu.cos from comment #19)
> The bug is still reproducible on build: Aurora 27.0a2 (2013-11-22).
> Device: Asus Transformer Tab (Android 4.0.3)

I pushed this patch to Aurora one hour ago. It's not in the latest Aurora build yet I suppose.
(Reporter)

Comment 21

5 years ago
Verified as fixed in build: Aurora 27.0a2 (2013-11-24).
Device: Asus Transformer Tab (Android 4.0.3)
Status: RESOLVED → VERIFIED
status-firefox27: fixed → verified
Attachment #8335953 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
status-b2g-v1.2: --- → fixed
(Reporter)

Comment 24

5 years ago
Verified as fixed in build: 26.0b1 beta 8 (2013-11-26).
Device: Asus Transformer Tab (Android 4.0.3)
status-firefox26: fixed → verified
You need to log in before you can comment on or make changes to this bug.