OS native dialogs exceed screen height on smaller screens

RESOLVED INVALID

Status

Thunderbird
OS Integration
RESOLVED INVALID
5 years ago
2 years ago

People

(Reporter: Ulrich Moser, Unassigned)

Tracking

24 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131028113308

Steps to reproduce:

Save an attachment on my netbook (details see What happened?)


Actual results:

Besides my large notebook I use THunderbird under xubuntu 12.04 LTS on a netbook with only 1024x600 of screen resolution when I am travelling. Same model is used by my wife for reporting her working hours while visiting her different clients. When accessing Dialog like the Save Attachment Dialog this exceeds the screen height so that the buttons are not visible. Because the dialog bos already hits the panel it cannot easily be moved up and resizing is difficult especially with the trackpad not being exact enough.


Expected results:

Thunderbird should get the size of the working area except the panel height and request a meaningful dialog size.

Comment 1

5 years ago
I am not sure whether TB actually can affect the size of these dialogs. It appears to me that the Add attachment or Save attachment are system dialogs taken from the underlying OS (e.g. Ubuntu in your case). So maybe you can tweak the contents of these dialogs globally in your desktop environment (KDE, GNOME, XFCE, Unity, etc.)

Comment 2

2 years ago
Yeah, I don't think we can impact the native dialogs
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Untriaged → OS Integration
Resolution: --- → INVALID
Summary: Dialogs exceed screen height on smaller screens → OS native dialogs exceed screen height on smaller screens
You need to log in before you can comment on or make changes to this bug.